Adding a link to a canned reply

I just tried to add a link to an existing canned reply. When I ctrl-k’d, the link-editing popup replaced the canned reply-editing popup and I lost all my edits. :cry:

1 Like

Oh no! I’ve just tried to reproduce the issue on my hosted Discourse site. When I open the insert link modal with ctrl-k, I’m not actually able to insert the link. Instead, I get the following error in my browser’s console: Cannot read property 'querySelector' of null called from discourse/d-editor.js at main · discourse/discourse · GitHub.

I’m not sure if this should be a feature request or a bug report. I guess the feature request is to support using the insert link modal when editing canned replies.

What browser and operating system were you using when you lost your edits?


I’m on Ubuntu/Chrome

Also, I should maybe have added to the OP that the link popup seemed to behave a little oddly: I couldn’t esc out of it.


Can we still repro this @simon?

Testing this just now, if I hit Ctrl + K to open the link modal when creating a new whisper, after clicking the “OK” button to insert the link, the canned reply that I was composing disappears. I am not seeing any errors in my console. Testing this with the latest Chrome browser on Ubuntu.

I’m assuming the issue is related to both “Add Canned Reply” and “Insert Hyperlink” using modal windows. When the Insert Hyperlink modal is opened the Add Canned Reply modal automatically closes.

1 Like