Unable to copy paste into a new canned message

See screenshot. I am adding a canned reply, and want to copy/paste the text into the content box. Weirdly, the text I am pasting shows up not in the canned reply content but in the body of the message behind, in the composer. I can click into the content box and type in text.

4 Likes

I can repro this bug even here on Meta.

Steps to reproduce:

  1. Write a text in the composer
  2. Open a canned reply and click New
  3. The text in the composer appears in the canned reply
  4. Click on X or Cancel has no effect.
4 Likes

I think @nbianca is working on some improvements here, maybe this can be addressed as well?

4 Likes

Great! Glad canned replies are getting even more love.

What @Dax is describing is a bit different from what I see on my instance.

Steps to reproduce:

  1. copy some text into your clipboard (looktthatIcanstartalistwithzerohowcoolisthat!)
  2. Start a new message
  3. Open canned reply and select new or edit existing canned reply
  4. Click into canned reply content field, paste clipboard text . See it appear in composer in greyed background, not appear in the canned reply content field.

I cannot reproduce any of these bugs. What browsers are you using?

This is how I tried:

  1. Write some text in the composer and had more in my clipboard.
  2. Press on the :gear: icon and then on Canned Replies.
  3. Press the :heavy_plus_sign: New button.
  4. I clicked on the composer input field and pressed CTRL + V to paste. It worked! :white_check_mark:
  5. I clicked on the composer textarea field and pressed CTRL + V to paste. It worked! :white_check_mark:
  6. Click on cancel. It worked! :white_check_mark:
  7. Re-did steps 1-6 and tried :heavy_multiplication_x:. It worked! :white_check_mark:

I have tried Chrome 69.0.3497.100 and Firefox 62.0 on Ubuntu 18.10. I did this here, on Meta.

4 Likes

For me this happens both on firefox and chrome, on windows.

Both Firefox and Chrome on Win10 and Ubuntu, see

Please note that the canned reply already has a title (“test”). This is the title of a canned reply that I had created and then deleted (via the trash icon) a few minutes before.

2 Likes

Aha! Got it. When you said that cancel or :heavy_multiplication_x: buttons do not work, I was under the impression that the modal would not close.

Thanks!

4 Likes

I fixed the bug @Dax reported a while back when I did the other general improvements.

About the other, I still cannot reproduce it. @tobiaseigen, can you please try again now and let me know if it still happens for you?

3 Likes