Admin dashboard won't load after upgrade to v2.1.0.beta3 +20

I rebuilt Discourse to v2.1.0.beta3 +20 following notification this morning that there was a critical update. There were no errors during the rebuilding. However, the Admin dashboard now returns a 502 after trying to load unsuccessfully for a few minutes.


When I SSH into the server and curl, the page seems to be returned. However, when trying to hit it externally, the following is in the Nginx log:

2018/07/27 18:01:50 [error] 309#309: *50963 upstream prematurely closed connection while reading response header from upstream, client:, server: _, request: "GET /admin/dashboard/general.json?_=1532713667907 HTTP/1.1", upstream: "", host: "", referrer: ""

Looking in /var/discourse/shared/standalone/log/rails/unicorn.stderr.log the following appears:

E, [2018-07-27T18:07:20.883373 #323] ERROR -- : worker=3 PID:12195 timeout (31s > 30s), killing I, [2018-07-27T18:07:26.991147 #12648] INFO -- : worker=3 ready

We’ve tried turning off Cloudflare and/or various components of it, including the firewall. Regardless, the admin dashboard won’t load. Everything else about the forum is working as expected. Everything was working as expected prior to rebuilding.

Every other part of the Admin section works as expected… it’s only the dashboard portion that won’t load.

Any ideas?

First step to try will be to purge cache from cloudflare

Second, Go to /admin/upgrade and upgrade to latest

if none of those solve this for you, third will be to rebuild the container

1 Like

I will dig more if upgrade doesn’t solve it. Let me know.


I’m on +21 and dashboard is loading fine as of now! as there is cloudflare involved, I’m almost certain that it is something to do with caching at their end but I can be wrong too.

Thanks, I’ll take a look. I have a sense it is Cloudflare, too, but our fiddling with it so far hasn’t been successful.

Easiest way to know if it’s cloudflare is to disable their optimizations by going to DNS and disabling it (turning orange cloud grey by clicking it) and then a force refresh byCTRL+F5


You really REALLY do not want all traffic going through CloudFlare to a Discourse instance. We’ve had dozens of issues with CloudFlare “accidentally” breaking Discourse over the last couple of years. Search here if you don’t believe me.

Ok, thanks. I’ll do some searching to try to figure out the best way to set it up. It should be fine just serving up images and cat gifs, etc. though, right?

I appreciate the support.

Ok, I did all of those things and none of them addressed the issue. We tried completely disabling Cloudflare and it still won’t work. It’s ONLY the bottom part of the Admin Dashboard page.

Now on v2.1.0.beta3 +30. Any further suggestions? I’m happy to give anything a shot.

1 Like

Can you post me a screen of what you see and the exact url you are on please ? Also do you see any error in the browser console?

The URL is “/admin”. Attachments below.

Admin dashboard trying to load. It sits here spinning for around 30s.

(Forum only allows me to post one image per post as I’m new.)

Admin dashboard after timing out:

Error console. Link in the error goes to “/admin/dashboard/general.json?_=1532826528550” if that matters.

Also just noticed I had uBlock origin enabled in these shots, the behavior is absolutely identical with it disabled.

Just to emphasize, Cloudflare is completely disabled for the entire domain.

I would add that I was mistaken in saying that using curl from the VM works on the URL. It does not.

does clicking on moderation tab works?

Yep, works fine. Loads very quickly and no errors.

Ok nice.

Does any one of these doesn’t load?


Also note, I’m trying to help you debug this here, but next week I will push a commit to make it way easier to know what the error is, instead of this “exception” window.

Every one of those URLs loads swiftly with no errors.

And good to hear! This isn’t mission-critical as the entire site works except that dashboard, but it is a bit annoying. Really appreciate your help on a saturday night!

Ok let’s way tuesday then, thanks for the debugging