After running setup wizard with Let's Encrypt, favicon not loading over HTTPS

(Brendan Schlagel) #1

Just made a new forum (woohoo!) with the standard Digital Ocean install, and enabled Let’s Encrypt on setup. I just finished running the setup wizard, and added images / icons through that process (nothing manually added / changed via settings). But I’m getting a mixed content warning re: the favicon when loading the site:

Mixed Content: The page at ‘https://athenaeum.antilibrari.es/’ was loaded over HTTPS, but requested an insecure favicon ‘http://athenaeum.antilibrari.es/uploads/default/original/1X/0342f90c1f8fb1f273f42078cb988fd78ecfab2e.png’. This request has been blocked; the content must be served over HTTPS.

EDIT: okay, just went to the admin page and saw this:

  • Your website is using SSL. But [force_https](https://athenaeum.antilibrari.es/admin/site_settings/category/all_results?filter=force_https) is not yet enabled in your site settings.

Seems like that’s a setting that should be enabled automatically if I’ve configured the automatic Let’s Encrypt setup during install? Or if not for technical reasons, should add “make sure to enable the force https setting” in the install guide.

Only tangentially related — on first hitting the admin page I also see a notice “Your site is missing a short title…” — maybe something else that should be part of the setup wizard.

2 Likes
(Jeff Atwood) #2

I wonder if there is a way we can connect success of this step with automatic setting of the site setting @tgxworld?

(Alan Tan) #4

I think I know a way to do so but I’ll have to try it out to be sure.

5 Likes
(Alan Tan) #5

This should do it.

6 Likes
(Alan Tan) closed #6

This topic was automatically closed after 6 days. New replies are no longer allowed.