After the update, the site did not open and the backup database was not loaded

When I ran this, it seemed to be working, but actually the problem was that the webserver was not working and we cannot understand it this way. When we enter the container and run this code, we can see whether nginx is running or not:

nginx -t

However, I would like to answer the problem in this topic by copying the solution from your message. The nginx issue is completely different, I am testing it in a separate domain with a fresh installation. If it gives an error again, I will open a separate issue and report it.

The problem of the backup not working in the subject is caused by a table or record that is no longer used. I think it was a record that the chatbot plugin no longer uses, but this was not deleted during the update. I think the plugin author friend has solved this, you can rest easy :slight_smile: I deleted the error line, repackaged it and installed it from the admin panel, it works without any problems. Or you can also download from the server:

Explanation of fixing corrupted plugin file in is:

  • Ungz a backup: tar -xvzf foo.tar.gz
  • ungz the dump.sql file
  • remove the offending lines that build the unwanted index:
– TOC entry 8020 (class 1259 OID 84313)
– Name: hnsw_index_on_chatbot_post_embeddings; Type: INDEX; Schema: public; Owner: -

CREATE INDEX hnsw_index_on_chatbot_post_embeddings ON public.chatbot_post_embeddings_old USING hnsw (embedding) WITH (dims='1536', m='64', efconstruction='64', efsearch='64');
  • zip back up the dump.sql file
  • combine it in a directory with your uploads folder
  • targz the whole thing back up
  • manually restore this file

If it gives you the error of a different table, I think it will be fixed if you delete the table that contains that record using the method above.

My site, which I worked hard on and was starting to grow, was down for two days. Let’s not forget a sleepless night and a day. There is always the possibility of such events happening to us. Don’t forget to make a backup and check that the backup is working. I would like to thank my brother @merefield for helping me during this process. We learned new things together.