After the upgrade of discourse-solved today, my site collapsed

The site is blank and seems always loading, finally out of memory…
When I disable the plugin, site is coming back to nomal as usual :rofl:


Thank you! I was having the same problem. Disabled all the theme components and it still didn’t work…

what have you done about it :joy: @Dannii

There is an open PR on an unresolved deprecation issue but I don’t know if that would be the cause.

It’s my bad I think … I’m taking a look :blush:

weirdly, tests passed.


A fix is on its way. :slightly_smiling_face:


Ha, funny, I’d just seen this:


thanks @David for picking this up.


It’s even documented in the deprecation notice :man_facepalming:

or if you still need the fallback shim, use import { getOwnerWithFallback } from 'discourse-common/lib/get-owner';

Sorry for the disruption!


No worries, this kind of thing really should’ve been picked up by the test suite! We’ll look at improving that soon :eyes:

PR is now merged, so please try running an update on discourse-solved @Dennis_P_Z @Dannii


Even when something goes wrong you guys are amazing. :tada: :slight_smile:


Thank you team for the quick action @david @merefield @Arkshine @Dannii


Still failing for me after updating discourse-solved to the latest revision:

solved-status-filter.js:32 Uncaught (in promise) TypeError: (0 , s.getOwnerWithFallback) is not a function
    at shouldRender (solved-status-filter.js:32:1)
    at plugin-connectors.js:166:1
    at Array.filter (<anonymous>)
    at e.renderedConnectorsFor (plugin-connectors.js:164:1)
    at get connectors [as connectors] (plugin-outlet.js:126:1)
    at Ce (index.js:1251:1)
    at reference.js:175:1
    at reference.js:136:1
    at e.track (validator.js:668:1)
    at f (reference.js:135:1)
    at index.js:5588:1
    at reference.js:136:1
    at e.track (validator.js:668:1)
    at f (reference.js:135:1)
    at index.js:5588:1
    at reference.js:136:1
    at e.track (validator.js:668:1)
    at f (reference.js:135:1)
    at reference.js:312:1
    at reference.js:136:1
    at e.track (validator.js:668:1)
    at f (reference.js:135:1)
    at Object.evaluate (runtime.js:3440:1)
    at Object.evaluate (runtime.js:1052:1)
    at It.evaluateSyscall (runtime.js:4263:1)
    at It.evaluateInner (runtime.js:4234:1)
    at It.evaluateOuter (runtime.js:4227:1)
    at (runtime.js:5058:1)
    at Wt._execute (runtime.js:5045:1)
    at Wt.execute (runtime.js:5038:1)
    at Qt.sync (runtime.js:5105:1)
    at wr.render (index.js:6749:1)
    at index.js:7013:1
    at Mt (runtime.js:4139:1)
    at Tr._renderRoots (index.js:6996:1)
    at Tr._renderRootsTransaction (index.js:7039:1)
    at Tr._renderRoot (index.js:6985:1)
    at Tr._appendDefinition (index.js:6911:1)
    at Tr.appendOutletView (index.js:6899:1)
    at p.invoke (queue.ts:203:14)
    at p.flush (queue.ts:98:13)
    at h.flush (deferred-action-queues.ts:75:19)
    at $._end (index.ts:616:32)
    at _boundAutorunEnd (index.ts:257:12)

Hi Andrea, welcome back :wave:

Based on this error getOwnerWithFallback is not a function, it looks like you need to upgrade Discourse in order to make the plugins work.

@Arkshine Thanks! Any idea which Discourse release/ tag would contain that function? We’re consuming Discourse releases through [1].


[1] Docker

Related commit: DEV: Rename custom getOwner to getOwnerWithFallback (#23437) · discourse/discourse@8958b4f · GitHub

The change happened three weeks ago. (sept 26) ; I think starting from 2.0.20230927-0028-slim, should be good.

1 Like

Confirming that updating seems to have fixed the problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.