All outgoing email has been globally disabled by an administrator


(Dan Dascalescu) #1

Just saw this message appear at the top of my forum:

All outgoing email has been globally disabled by an administrator. No email notifications of any kind will be sent.

I was re-running an import script. Still using Gmail, but /logs doesn’t show anything for the past 24 hours (Debug through Fatal are checked).

UPDATE: after reloading the page, the message is gone. What might’ve happened?


(Rafael dos Santos Silva) #2

The import script probably disable emails during import so it’s fast and doesn’t send emails with unfinished data.


(Ján Janočko) #3

Hello, I have intentionally disabled all outgoing emails. Now all users see the message on the top of the forum: All outgoing email has been globally disabled by an administrator. No email notifications of any kind will be sent.

How can I disable this message? (Having outgoing emails still disabled)


(Ján Janočko) #4

OK, I got this quite fast.

Just need to add CSS customization:

.alert-emails-disabled {
    display: none;
}

(pprp) #6

I have tired to restore from UI, and restore got failed, and I got message:

All outgoing email has been globally disabled by an administrator. No email notifications of any kind will be sent.

root@xxx-app:/var/www/discourse# rails c
[1] pry(main)> SiteSetting.disable_emails = false
Discourse::InvalidParameters: value
from /var/www/discourse/lib/site_settings/type_supervisor.rb:181:in `validate_value'
[2] pry(main)>

but it does not help,

please let me know, how to remove this message and enable notifications.
Thanks.

@Falco, please let me know how to remove message and enable notifications.


(Rafael dos Santos Silva) #7

Try SiteSetting.disable_emails = 'no'.


(pprp) #8

thanks very much.

I have set “disable emails” to “no”, at /admin/site_settings/category/emailI, then it worked.