"An error occurred: The requested URL or resource could not be found." when trying to delete user in moderation queue

When I tried to delete a new user who’d posted a load of foreign-language spam I got this message. I’m on 2.9.0beta14. It was the same whichever of the two “delete” options I chose.

Edit: Just noticed that the user did get deleted (“Deleted via review queue”) so maybe I just clicked the button too many times.


I’m also getting this repeatedly with 3.1.0.beta2. The user is deleted despite the error message (and I’ve only clicked once).


Sorry for the delay, I meant to reply to this one at the time, but for some reason did not get round to posting the draft…

I also see this a fair bit when deleting spam users. Everything works as expected, but you do get the “An error occurred…” modal pop up, which can be misleading.

To replicate:

  • Sign up test user
  • Paste a chunk of Lorem Ipsum in for their first post to trigger 'New user typed their first post suspiciously fast, suspected bot or spammer behavior.`
  • When reviewing, select ‘delete user’
  • Receive error modal (though everything has worked and the user has been deleted)