Android app keeps crashing

I have been using the Android app on my Galaxy S7 (on Marshmallow) for over two years but now it suddenly stopped working. It crashes directly after starting it. However, the exact timing of the crash is inconsistent: sometimes, I hardly get to see the app at all and sometimes I get to see my list of discourse sites and (very rarely) I get to open one of them but then the crash happens.

I have tried all kinds of things before I uninstalled and reinstalled the entire app but to no avail: the first time I started the newly installed app, I didn’t even get a glimpse of the app screen. Second time it briefly flashed up with an empty screen (except for the menu bar at the top), third time I got the screen asking me to connect to a Discourse instance but tapping for example meta did nothing. Not sure if it eventually crashed or if I killed it but after a couple of more tries, I actually was able to connect to meta. Two hours later, however, it was disconnected again (this is provably a different issue, though) so I reconnected to meta and it seemed to work (new and unread count was displayed) but tapping on meta did nothing at first and after a few seconds the entire app crashed again. Upon restart, it was disconnected again.

Tried adding a different discourse instance and the app crashed immediately.

Note that all discourse sites worked fine in Chrome during all testing.

3 Likes

Any ideas @pmusaraj of things to look at?

Can you share your Android version and app version?

4 Likes

Sure. Android 7.0 (I thought I was still on Marshmallow, but there you have it: I did upgrade at some point) and discourse app version 1.5.0.

3 Likes

I can’t reproduce this on a 7.0 (Nougat) emulator. Can you try the beta version at https://play.google.com/apps/testing/com.discourse it should be version 1.5.2 and it is packaged differently, so maybe that’ll fix your issue.

2 Likes

It took a while until I got the beta after signing up (it looks like you only get future betas after signing up, not the current beta at the time of signing up) but I now have it installed and will let you know if/when the issue reoccurs.

4 Likes