Android app stops on authorization

I just reinstalled Discourse on a new phone. I input and another site. When I try to connect to I get “Authorize application access” “Discourse - LGL157BL” (my phone) is requesting the following access to your account: and a bullet list with an [Authorize] button. If I click the button, the app stops.

Android is Nougat, App is installed from Google Play


tried to uninstall/reinstall the app?

I can see your crash, it seems like there’s some issue when generating keys:

com.discourse_issue_5_crash_5C78E96A020800015959244D810408CC_DNE_0_v2.txt (29,8 Ko)

Not sure of it’s some Device/Android version specific issue, or something else. Try to reinstall first.


Uninstalled, reinstalled, Still the same issue. It worked fine on my other phone, which was the same model phone.

Out of curiosity did you try on different Discourse instances ?

And yes I expect it to be a very specific issue has there are almost no crash on the android app which sits at 99,47% crash free sessions.

It makes no difference what I try to open. I grabbed my old phone, which works, but has a cracked screen, turned on the wifi and Discourse is fine, runs beautifully, no Access screen, just a log in.

Oddest thing is that I’m still getting notifications from Discourse on the new phone, but I can’t look at anything because of that “Authorize application access”

I tried rebooting the phone. I’ve uninstalled / installed several times. It worked / works fine on the old phone - same android, same model. It’s utterly useless on this one. I’m beyond done with it.

I give up. This app is worse than useless to me. I can’t use it to look at my forums, all it does is constantly give me notifications on things I can’t look at. Uninstalled F-

Sorry about that, it looks like an incompatibility specific to the device.

The good news is that you don’t need the app, as Android Chrome offers native notifications.

I don’t buy it. My old phone is fine, the app runs fine, I never had - or have - any issues with it at all. Same exact phone /model / app / carrier. Nothing different at all. How can it be device specific if the same device runs it fine?

Chrome isn’t an improvement. I hate chrome.

Although not supported, Firefox on Android works well and support native notifications too!


I had the same problem.
Discourse forum is running Fine
I have installed the APP on android, it work fine also accesing my forum, forum and others.
At some time I changed my forum address. Then I had to delete the access on the app and create a new one.
This works for my users (nobody has reported incident, and I check with some on their android and it works fine), but doesn’t work in my case.
All the others access are running fine but the one to give e an error message

Authorize application access
“Discourse - HUAWEI P20 Pro” is requesting the following access to your account:
. Read and clear notifications
. Read user session info

If I click on Authorize I get this message

The sofware powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.
Detailed information about the error was logged, and an automatic notification generated. We’ll take a look at it.
No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site’s feedback category.


 I deleted the APP
 reboot the device,
 re-installed the APP
 No site configured, then I reconfigured the site.
 And it works.

Don’t know the issue but it seams to be solved

For me it says this

No need to create multiple topics on this @Bicurious_Girl. Looks like similar resolution as above, not sure if we can repro.

ok in the other post someone solved the problem but I tried it and didn’t work still says the same message

I have the same problem too and still nothing works

Should I just use this app instead of the site in discourse if I can’t authorize it

Just use the web browser. Much easier.

Ok I just both the chrome app and discourse site

Keep trying. It’s apparently something erratic. I installed the other day and it actually worked—may it will work at some point.