Android app can't see my discourse

Unless I’m missing some setting I have to enable on our end, the official app won’t connect to

It works with Meta just fine. In fact I’m posting from it now…

Not sure, this is a question for @sam.

1 Like

Maybe missing protocol and https redirect is not in place

Could you explain in a bit more detail (for this self-taught imposter-sysadmin!)

Our https setup predates Let’s Encrypt, but I remember following a guide here on meta line by line.

I thought Official App worked only with Hosted sites. Am I wrong, or do I misunderstand his question?

try adding https:// before, does it work? are you updated to latest? my guess is that there are issues with the http redirect.

1 Like

It works fine with all discourse site provided they are running latest, but you get no push notifications.

4 Likes

I see. But you can still get mobile notifications with discourse-push-notifications plugin, just not through the App, right?

3 Likes

Yeah, but clicking on the notification will open Chrome, not the app.

And that is Android only.

4 Likes

I have the same issue with talk.libreho.st. I have successfully installed in the app 10 Discourse instances on TLDs ranging from .org to .wiki and .network, but this one fails.

  • :white_check_mark: responds to port 80 with 301 redirect to port 443
  • :white_check_mark: has a valid SSL certificate
  • :white_check_mark: no error logged on the web server

Checked with:

  • curl -I -v http://talk.libreho.st/
  • curl -I -v https://talk.libreho.st/

Tried both without and with the scheme.


Edit: I’m running version 1.2.1, will upgrade to 1.3.0 first…

I tried to add talk.libreho.st with success

Android 9, Huawei mate 20 pro.

5 Likes

Thanks @Dax. I upgraded to 1.3.0, and it still fails. I have no idea why. Other domains work fine.

talk.libreho.st Works for me too on iOS, which suggests it’s your test device.

5 Likes

Are you using a Samsung phone running Android 7 ?

3 Likes

Yes, it was a Samsung phone with Android 7.

2 Likes

Right, we know it was in your case, since you helpfully reported it – we were asking @hellekin if the same thing applies to him. Sorry to bug you :stuck_out_tongue:

I’m using a non-rooted Android 7.0 with MicroG installed and no Gaggle account. I’m trying to upgrade everything, test with various things enabled or disabled. After resetting all apps and rebooting, I found that there’s one system app remaining disabled and that is not possible to enable: “Android System WebView”. After some research I have managed to update it by disabling Chrome, then updated it, and re-enabled Chrome. I tried to update Chrome from 63 to 73, but the system tells me I must use “root or privileged install”. Then I updated everything, re-enabled all Gaggle apps and Discourse app. Still no luck. This is very strange.

That sounds very very hard to support.

1 Like

I cannot see any reason why .st would fail only on my device. If you know of another Discourse instance on this TLD, I’d be happy to test that as well.

Did you read the link from @falco above? It’s unlikely to be the domain and more likely to be the specific ecdh handshake.

3 Likes