Attachments aren't included in first group PM post


(Michael Downey) #1

Continuing the discussion from Allow all email attachments for group messages setting?:

Following up on the site setting Allow all email attachments for group messages

My question:

Would there be any reason why attachments are only getting processed in replies to a group-based PM, and are skipped/not processed in the initial post within the PM “topic”?

In other words, imagine non-registered email address user sends an email to group@discourse.example.org with a PDF attachment for the group to read.

  • Expected behavior: User staged, attachment appears in first post of the new PM topic and is downloadable. Attachments included in subsequent email replies to the PM topic also appear.
  • Actual behavior: User staged, attachment does not appear in first post of the new PM topic, but does appear in subsequent email replies to the PM topic also appear.

The allow all attachments for group messages site setting is enabled.


(Michael Downey) #3

Thanks! Would be good if someone else can attempt to reproduce this … it could certainly be a configuration problem on my end!


(Jeff Atwood) #4

Can you repro this @jomaxro?


(Joshua Rosenfeld) #5

Sure, I can do some testing.

@downey, is pdf in the authorized extensions site setting?


(Michael Downey) #6

Yes, I’ve added it there.

PS: Should stripping attachments by email be logged anywhere that I might check?


(Joshua Rosenfeld) #7

You can check the email log, click the icon next to the timestamp.

Now I’m confused though, if you enabled pdf across the entire site and an authorized extension, allow all attachments for group messages is meaningless, at least as far as pdf files are concerned. I’ll do a quick test, but I’m 95% certain we get PDFs in initial group PMs.


(Joshua Rosenfeld) #8

OK, test completed here on Meta. I was able to email a PDF into our team inbox. Going to need more info to test with here.

pdf is in the authorized extensions list, and allow all attachments for group messages is enabled.


(Michael Downey) #9

Hmm. I can no longer reproduce the problem, so will close this out (with the above good recommendations for others!) and keep a close eye on it. Thanks all.


(Joshua Rosenfeld) #10

Sounds good. Flag to reopen if you can reproduce this in the future!


(Joshua Rosenfeld) #11