Attempted DigtialOcean migration killed Discourse

unsupported-install

(James) #1

I was following along with the tutorial to move my 1-click Discourse droplet to a team account. Nothing worked so I just turned my old droplet back on and haven’t been able to access the forum since. When I SSH into the droplet it looks like Discourse isn’t running at all. I did an app rebuild and at the end of it all I got this message:

/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint app (09cdfaaa994ed6d7ad723cc121cdfb923a68109f20c48edee0bb45fb7113e2d5): Error starting userland proxy: listen tcp 0.0.0.0:80: listen: address already in use.

I don’t know if that’s the whole problem or just part of it. Any ideas?


(Matt Palmer) #2

That certainly won’t be helping, certainly. You’ll need to contact DigitalOcean support, though, because we don’t have any input or control over their one-click installer.


(Jay Pfaffman) #3

I can probably figure out, but there are too many unknowns to solve it here

If you’d like my help and have a budget of $300 to $500, my contact info is on my profile. I’m traveling today, so I might not be able to respond immediately.


(James) #4

I ended up doing a fresh install per the Discourse guide. It’s better anyway because I can get proper support now.


(Jay Pfaffman) #5

Great! Glad you got it worked out. A standard install is definitely what you want!


(Sam Saffron) #6