Authentication is required error when pulling repo


(salaxander) #1

Hi everyone, I am having some trouble completing the installation on red hat enterprise linux 6.5.

Everything is working fine up until the bootstrap process. When I run bootstrap I get the output

Unable to find image 'samsaffron/discourse:1.0.5' locally
Pulling repository samsaffron/discourse
2014/10/14 14:14:09 Authentication is required.
Your Docker installation is not working correctly

I think this could be due to some corporate proxy shenanigans. Could anyone possibly help me with this? I feel I should be able to just manually download that repo to skip the fetch step, but I’m not sure where I would need to place it.


(lid) #2

(salaxander) #3

I have now tried configuring the proxy in the app.yml file and I still get the same error. Can anyone provide any insight?


(Sam Saffron) #4

The host needs to be able to get to the net, try.

docker pull samsaffron/discourse


(Jonas Friedmann) #5

I have the same issue (./launcher rebuild app ends in Unable to find image 'samsaffron/discourse:1.0.5' locally).

However, running docker pull samsaffron/discourse does just fine. I’m not sure what to do, right now.