Automatic custom group assignment not working automatically


(Jonathan Johnson) #1

I’m using the omnibus version of the distribution and am on Discourse 1.8.10. I created a custom group for my employees, and I entered in the “Users who register with an email domain that exactly matches one in this list will be automatically added to this group” my domain, e.g., “google.com”. I clicked the box “Apply the same email domain rule to add existing registered users”.

Once I click save, every existing registered user with an email domain that matches is added. That’s great.

I then when into a new browser and tested with a test email account I set up, and upon registering, the new user is NOT part of the custom group. In the admin, if I open up the group I don’t see the user there.

If I click “Save” without changing anything else, the new user is then added to the group.

Users are currently set up to log in with Google OAuth, but I also temporarily allowed local logins and couldn’t get this automatic group assignment to work with either mechanism.

I’ve tried searching for a solution, but I can see people using the feature but no one saying it’s not working for them. Is there some configuration option that would cause the flow I’m seeing above? Or is this a bug and should be moved to that category?

Update: Logging out and re-logging in assigns the group automatically. So it’s just initial login that is the issue. This makes me think it’s because of the whitelisted email domain not requiring email address verification. (It’s not, I just tested that theory)


(Jeff Atwood) #2

You’ll need to upgrade to 1.9 to get detailed support on stuff like this, it might even be fixed in latest.


(Jonathan Johnson) #3

Latest is beta, and I’m trying to run this on a production site. Should I be running a production site on beta? I guess to me it seems reasonable to ask about this sort of thing since I’m on the latest non-beta version available.

I can certainly try to find time to test on a non-production VM.


(Jeff Atwood) #4

This site is on beta. All our customers are on beta. I hope that definitively answers your question


(Jonathan Johnson) #5

That is definitely good to know. I’ll try out the beta tonight and reply with my findings.

Thanks!


(Barry van Oudtshoorn) #6

It sounds like this could be the same issue as

if you’re experiencing this issue with Google OAuth.


(Stephen Chung) #7

Google Maps has been on beta for years after widespread use. But I won’t trust a non-beta 1.0 Technology from Microsoft.


(Jonathan Johnson) #8

There is a difference between software that offers both a stable and a beta channel and software that only has a beta (the google style of betas).

However, the good news is that this is solved in 1.9.0-beta14. Thank you @codinghorror for pointing me in the right direction of simply upgrading.I’ll stick to beta now that I understand better how it applies to this software, and for anyone else reading, here’s why in a bit more detail.