Blank page after install on CentOS 6.6


#1

I’m trying to install Discourse on CentOS 6.6 running on my VM on my local box. I’ve followed instruction on http://www.howtoinstalldiscourse.com/how-to-install-discourse-on-centos/. I got it running, but all i got is a blank page with these errors on my Chrome developer tools console:

GET http://localhost.newlum:85/assets/preload_store-df49ca825a94fb1f1c180909abe34900.js
GET http://localhost.newlum:85/assets/locales/en-4091e96b228c0c127f871d1f56ea5fa1.js 
GET http://localhost.newlum:85/assets/vendor-6bf32a916dad1985b0362055d3458364.js 
GET http://localhost.newlum:85/assets/application-dc2fd9818162f1ceb549f130951c1f25.js 
Uncaught ReferenceError: PreloadStore is not defined(anonymous function)
Uncaught ReferenceError: Ember is not defined(anonymous function)
Uncaught ReferenceError: Discourse is not defined(anonymous function)
GET http://localhost.newlum:85/assets/browser-update-fd9405eb2b168d517a8ab2e955a292e2.js 

I don’t think the js files are loaded properly, maybe some kind of permission issue, but have no idea how to fix, as I’ve never used docker or nginx. If you can give me some pointer would be great. thanks!


(Jeff Atwood) #2

I doubt Docker is installed correctly.

What does docker --info and docker --version report?


#3
[root@webtools discourse]# docker info
Containers: 1
Images: 7
Storage Driver: devicemapper
 Pool Name: docker-8:3-8390243-pool
 Pool Blocksize: 65.54 kB
 Backing Filesystem: extfs
 Data file: /dev/loop0
 Metadata file: /dev/loop1
 Data Space Used: 2.042 GB
 Data Space Total: 107.4 GB
 Metadata Space Used: 2.077 MB
 Metadata Space Total: 2.147 GB
 Udev Sync Supported: true
 Data loop file: /var/lib/docker/devicemapper/devicemapper/data
 Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
 Library Version: 1.02.89-RHEL6 (2014-09-01)
Execution Driver: native-0.2
Kernel Version: 2.6.32-504.8.1.el6.x86_64
Operating System: <unknown>
CPUs: 2
Total Memory: 3.736 GiB
Name: webtools.lcs.local
ID: E4AJ:AZ7T:YVXB:EZYA:L3O3:GJ25:MUIY:2L5B:YFII:GJS7:OLP5:VI5O


[root@webtools discourse]# docker version
Client version: 1.5.0
Client API version: 1.17
Go version (client): go1.3.3
Git commit (client): a8a31ef/1.5.0
OS/Arch (client): linux/amd64
Server version: 1.5.0
Server API version: 1.17
Go version (server): go1.3.3
Git commit (server): a8a31ef/1.5.0

(Jeff Atwood) #4

Devicemapper is not supported. It’s super buggy in Docker. You need AUFS working.

Also that’s an old version of Docker, the current version is 1.6.1 or higher.