Blank White page throughout the forum


My forum was working fine till yesterday, and all of sudden, it goes white.

It is in DigitalOcean; I tried reboot, rebuild, increased RAM and everything. Still same.

Any idea?

It seems like you’re using cloudflare in front of discourse have you tried disabling cloudflare to verify if that fixes your problem?


Have you installed any plugins? But you should check out error logs, there may be a lot of error 5xx.

Sorry, this doesn’t help you a bit because I just can’t understand how docker, rails etc works, but everywhere else this is comes when webserver is broken, PHP is crashed (well this doesn’t apply here) or app itself is broken at style/theme-level.

Or have you messed up app.yml?

Quit soon someone who knows better will guide you, but they will ask at least what is happening at error logs.

Spin up new 5USD droplet, install a new Discourse and try to restore your forum. Then you know if there is some issue on system or discourse.

Can you generate backup via SSH?

That’s the likely issue.

You can look in the javascript console for some clues.

You should disable Cloudflare Rocket loader. It does not work with Discourse.

1 Like

I tried disabling Cloudflare. Still same :frowning:

Thank you so much for your help. My Forum is back after disabling Cloudflare Rocket Loader :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.