Site broken due to CloudFlare Rocket Loader

I upgraded my forum to resent update yesterday. After the upgrade forum is showing a blank page.
I have rebuilt app using ./launcher rebuild app command but nothing happened.
Please help to resolve the issue.

You can try running discourse-doctor. It might provide some clues.

What do you mean that “nothing happened” when you did the rebuild?

An easy solution that works for me.

  • Assuming, you have Backup
  • Also, take backup of app.yml to see plugin name and SMTP details.
  • Re-install Discourse and forget about it.

Nothing happened means it is still showing blank page.

Did you try discourse-doctor? Have you tried safe-mode? Do you have non-standard plugins installed?

safe-mode is also showing to select the option but when I select all three it sill shows blank page.
I have installed following plugins can you tell me the wrong one.

      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
      - git clone
1 Like

First remove all of the ones that don’t have “discourse” after

1 Like

Removed and rebuild app but results is same.:frowning_face:

Try in safe mode, perhaps one of your theme elements is broken.

I seem to have the same issue after the update taking an extremely long time.

I’ve disabled all plugins at this point and even tried safe mode. Safe mode doesn’t appear to do anything either, unfortunately. Still greeted by a completely white page.

Moreover, I’ve noticed that the site works until you log into the site. If you’re a guest, it works just fine. I thought that this was perhaps a caching issue with CloudFlare so I cleared the cache and even enabled development mode to make sure nothing was being cached and I would see changes live.

I’ve also tried rebuilding to no success after removing said plugins.

It should also be known that I can still access the admin page just fine, however you cannot navigate away.

I seem to be stuck. I may end up starting over from a backup – I can’t get Discourse functional despite the suggestions and some fixes others found.

As an update, I removed the container and completely started over and restored from a backup. I was hoping that maybe, just maybe I’d get past this whole issue. Unfortunately no, the issue returned. As soon as you log in, no content is served to the user. :frowning:

Figured this would help describe my issue:

Boy, lots of edits. I decided to open up the dev console to see if anything was there, found the following:

 [Show/hide message details.] ReferenceError: require is not defined[Learn More] _preload-application-data-4f43211de8a1f76fb8517554d5f9476615a1073e596b45352abcc0f64a8301d2.js:5:8
[Show/hide message details.] ReferenceError: Ember is not defined[Learn More]
[Show/hide message details.] ReferenceError: require is not defined[Learn More]
DEBUG: For more advanced debugging, install the Ember Inspector from ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:1:257655
r.get(...) is undefined

Safe mode is also unable to solve the problem.
Please check it and help me.

Disable CloudFlare Rocket Loader feature.


See, I saw suggestions for disabling Railgun but I don’t recall seeing anything regarding Rocket Loader. You’ve literally saved my assets.

I was about to make a post regarding it working up until I restored from a backup and I found that quite odd. Thanks CloudFlare! (Though it’s not their fault, I’m sure Rocket Loader works well when it’s intended to be used.)

If you’re using CloudFlare on your forum, verify that you have both Railgun and Rocket Loader features disabled via the control panel. Both of these options are found under the Speed category on the CF control panel. Again, huge thanks to @zogstrip for bringing this to my attention.

Thanks a lot!


Problem resolved

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.