Bootstrap app causes system crash and reboot


(ThinkingQuest) #1

Hi everyone,

I’ve installed discourse on my own pc running ubuntu 14.04, and another virtual machine running centos 6.6, both works fine.
Now the problem comes that When I try to install discourse on a server running CentOS 6.5, everytme I run /var/discourse/launcher bootstrap app, the system crashes and reboot automatically.

Could someone help ?
Where should I check for the error log please?

The kernel version is 2.6.32-431.el6.x86_64, I’ve checked the docker’s document, docker should be ok to run on CentOS 6.5 with kernel version 2.6.32-431.

Thanks in advance.


(Jens Maier) #2

Kernel 2.6 does not support aufs3, so you’re most likely running Docker with the devicemapper storage layer. This is known to cause all sorts of problems and is not supported. Upgrade to kernel 3.14 or later.


(ThinkingQuest) #3

Thanks for your suggestion.
I have solved this problem by running “yum update”. The kernel version updated to 2.6.32-504.16.2.el6, and it works now.

I will try to upgrade to kernel 3.14 or later.


(g0st) #4

yum update didn’t fix it for me. Is there some other option I can try short of upgrading the kernel?


(Jeff Atwood) #5

You really need a newer kernel.


(g0st) #6

DO doesn’t make it easy for CentOS users. Migrated to Ubuntu 14.4 and all is well.