Broken text editor (including in safe mode) after installing and uninstalling plugins


New discourse instance here:

I tried to install three plugins (discourse-checklist, retort, discourse-math) earlier, and immediately noticed my text editor was broken:

  • There are no markdown and emoji tools
  • No preview (tried to click the arrows a few times)
  • Drafts don’t seem to be auto-saved anymore
  • There are no javascript errors in the browser console
  • I tested on both chrome and edge

The text editor is broken in the same way for creating new topics and post replies.

So I immediately commented out these three new plugins and rebuilt, my current app.yml plugin section looks like this:

## Plugins go here
## see for details
    - exec:
        cd: $home/plugins
          - git clone
#         - git clone
#         - git clone
#         - git clone

After rebuild and restart, the functions of these plugins are gone, however, my text editor is still broken.

I’m at loss here since there are no javascript errors, have no idea how to troubleshoot or go back to the previous state before I installed these plugins.

Try selecting a category.

It doesn’t help. Post replies have the exact same issues.

My site (updated 12 hours ago) is “broken” as you describe until I select a category, then it’s fine.

Nevermind, I found out the theme I used was breaking it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.