Bug? IE 10 users who try to access a restricted group are told their browser is too old


(Clay Heaton) #1

@martinduparc (FYI)

We have users on IE 10 who need to join a restricted group in order to view a category specific to their department. Discourse works fine for them, in IE 10. However, some of them are not members of the group they need to be part of to see the relevant category. When they try to visit the category page, instead of being shown a message that they do not have the proper permissions to view that content, they are shown a message that says that their browser is too old to work with Discourse and that they need to use a more modern browser. The click-through FAQ says that they need to use IE 10 or better. This is causing all manner of confusion.

Is this an old browser warning message that wasn’t properly removed? Everything else seems to work fine in IE 10.


(Jeff Atwood) #2

Weird so this is specific to the category page? Can you provide a more exact URL?

Are you sure these users are not running their IE in backwards compatibility mode?

@neil we can test this using our BrowserStack credentials.


(Neil Lalonde) #3

I can’t reproduce this. I tried Win 8.1, 8, 7 on IE 10, 10 Metro, and 10 Latest. I always get the “Access Denied” message. I tried logged in and anon, navigating directly to /groups/secret, and navigating via a link in a post to /groups/secret. I didn’t see the browser warning message.

@clay What are the steps to repro?


(Jeff Atwood) #4

So we

  1. Set up a permissions required category “foo”
  2. Try to visit the /categories/foo page in IE10

Is that it?


(Neil Lalonde) #5

Oops, I made the secret group but not the category. So I have a restricted category on Try and try to view it on IE 10. I get this:


(Clay Heaton) #6

Yep, that’s where it appears for us.


(Clay Heaton) #7

I’ll double-check the steps tomorrow at work. We were able to reproduce it today by simply giving the /c/categoryname link to somebody on IE 10 (no compatibility mode) who was not a member of the user group that had access to the category. When setting up the category, we removed all permissions for all groups except the one specific to that category. Use case here is creating a fenced area for private discussion amongst members of a particular department. On latest Discourse beta.


(Clay Heaton) #8

Well, we’re unable to reproduce it today outside of a VM unless we put IE 10 into IE 9 Standards mode. Yesterday we definitely got the message when in regular IE 10 mode. I guess you can close this as “could not reproduce.” Thanks for looking into it!


(Jeff Atwood) #9

(Kane York) #10

I’m guessing that your environment has IE defaulting to IE9 Standards Mode, possibly through Group Policy, and that’s how it happened.