Bug With Rebuilding version: v2.4.0.beta1

Context: I’m creating a staging site to test updating production to the latest version.

./launcher rebuild web_only fails with

chown: cannot dereference '/var/www/discourse/public/plugins/discourse-internet-explorer': No such file or directory

  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed
  #version: 760fbf0c417d09559dc3d4267df24e55e67e604a
  version: v2.4.0.beta1

Looks like it’s related to

Any ideas on how to work around this?

Yeah doing historic installs is not going to be easy, recommend you choose an earlier base image. You can control that with the base_image: .... element.


In the params: section?

It is a top level element

1 Like

Hi there! I seem to get this error on latest version (2.5.0.beta3) while bootstrapping (I have a container built and running, but need to rebuild it to remove plugins and fix some configs).
Are there any obvious ways to fix it or will I need to clean-rebuild with a downtime the users of the forum will hate me for? :slight_smile:

1 Like

Updating the discourse_docker repo before rebuilding the image worked for me.


By pulling the image or the repository itself? I will try that! Tyvm :slight_smile:

I meant pulling the repository itself. There are a few recent commits in discourse_docker repo that fixes the issue due to removed plugins. I was working off a month-old repo which didn’t have those fixes. A git fetch/git merge helped.

1 Like

Aye, tried that (forgot to come back here and say something, hehe). Working great now!

Thank you for the help :slight_smile:

1 Like