Bulletpoint generation broken

composer

(Sam McLeod) #1

When selecting a list and clicking the bulletpoint formatting button, it merges the list into one item.

For example:

  • Item one Item two Item three

Should have been formatted as:

  • Item one
  • Item two
  • Item three

Screenshots:

I have a list:

And after I click on the bulletpoint formatting button:


(Jeff Atwood) #2

That is the way it has always worked since launch in 2013. We just haven’t had time to improve it, and very few people use extensive formatting via toolbar buttons.


(Tom Newsom) #3

I would use this button a lot more if it worked :stuck_out_tongue:


(Sam McLeod) #4

I use it even though it doesn’t work and it drives me crazy, like, seriously every day. :gates:


(Tom Newsom) #5

I find myself doing keyboard paradiddles (HOME, minus, space, down, HOME, minus, space, down, HOME, minus, space, down) and I think to myself, “This shouldn’t have to happen in 2015.”


(Markus) #6

This makes the situation not better. This also happens when selecting a text area for quotes. The bullet points are disapearing.


(Erlend Sogge Heggen) #7

There’s a good chance this will be addressed in v1.5:


(Jeff Atwood) #8

Did we fix this @eviltrout? I agree the old behavior was pretty bad.


(Erlend Sogge Heggen) #9

I’m unable to reproduce the problem @sammcj describes, so this definitely seems fixed.


(Robin Ward) #10

Yup, I spent time on this when I redid the discourse editor.


(Jeff Atwood) #11