Can an admin change his email address?

It seems that I as an admin cannot change my email address (primary mail address) registered in the following page.


Is there any way to change it?

Are you using SSO for login or have the setting email editable disabled?

No, I am not using SSO.

I checked what “email editable” means.
It seems that this is used when users want to change their email addresses.

I want to change my admin email address.

I have the setting enabled and I get the option to change my email. The idea here is that an admin is also a user.

If you do not want to enable the setting, you may be able to change the email via ssh.

See: Change staff email address from console

1 Like

I clicked the link in the mail, but the discourse page says that “Oops, the page doesn’t exist or private.” How can I authenticate this? I registered my company’s gmail address.

Are you trying to open the link in a different browser? Is the link somehow http instead of https? Do you have a reverse proxy or cloudflare in front of your discourse?

1 Like

No. The link starts with “https.”
I don’t think I have neither a reverse proxy nor cloudflare.

I tried the link under secret mode, but it failed. I have tried it several times with Chrome.

Also, I want to change the email address of “primary.”
I don’t want to add a new address under primary.

Add a secondary address, then make it primary. This should allow you to remove the old primary address from account. I’m not sure if it will make a difference if the same email is also present as a developer email in app.yml

This could be the reason. Maybe discourse didn’t had a signed in session under the secret mode?

1 Like

I tried this under a normal mode and a secret mode.

Also, it is impossible to delete the old primary address since the second email is not registered.

I tried this with another email address, but it failed.

Something is definitely broken in your discourse. I just tested changing admin email on my sandbox and it works fine. You’ll have to check exactly what is not working as expected.

IIRC, changing email via ssh console doesn’t require a verification either so that is the easiest way if you’re having email related issues.

Another possibility could be with your email provider/email client/browser extension that is breaking the verification link. I’m not sure which one but it has to be one of these.

While this third one is unlikely but your discourse instance or a 3rd party plugin installed could also be causing this.

So what I’d suggest is that you change the email via ssh console and spend some time debugging the issue with your instance.

1 Like