Cannot login after upgrade


I cannot login as admin nor as any other user after an upgrade. Tried to rebuild by using ./launcher rebuild app but it did not have any effect. Still no login possible.

Any idea? What kind of information do you need to help me further?

Kind regards

1 Like

You might want to begin by being more specific about what your issue is. “I cannot login as admin nor as any other user” is very vague. A log entry of an error or a screenshot of errors you get would be useful. See the link below for instructions on how to get logs. You would probably look at the rails log.

Once you provide relevant log data and/or screenshots, we (the community) will be able to more effectively help you.


Login is running withoud end. No error message. Anyhow, the doctor gave a hint. Looks like app cannot be started.

root@debian-4gb-nbg1-1:/var/discourse# ./launcher start app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (34a973985c824743faf32d44ba96b910b54adb3413a9f2de411cd6fe2b122d8d): Error starting userland proxy: listen tcp bind: address already in use
Error: failed to start containers: app

Any idea what this issue is pointing to?

1 Like

Well, got it working. Checked ports, stopped nginx service and started app afterwards. Now container got started and I am logged in successfully by now.


Make sure that you Uninstall nginx.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.