Cannot make text bold in the middle of a word with asterisks


#1

That’s Numberwang


(Tobias Eigen) #2

this is not a bug. you may want to acquaint yourself with markdown: Daring Fireball: Markdown Syntax Documentation


(Mr.Burns avatar therefor TDWTF) #3

The problem is that the little editor thingy uses markdown. For example:

This is a demonstration where I highlighted “mon” in that word and hit the bold button in the editor.

To do that properly you can use HTML like so:

This is a demonstration where I bolded “mon” in that word using HTML.

As the broken one is how markdown is supposed to work the formatting buttons should not use markdown when they are inserting said formatting.


(jaming) #4

I think that is how markdown is supposed to work. From the link @tobiaseigen posted:

[Quote]Emphasis can be used in the middle of a word:
unfriggingbelievable
[/Quote]
Source

And see: Babelmark 2 - Compare markdown implementationsberwang


(Mr.Burns avatar therefor TDWTF) #5

OK, I’d not looked at the mess that is markdown so it is supposed to muck with things in the middle of words. If that gets fixed then I guess using markdown in from the editor’s buttons would work. Once they fix it that is.


#6

You mean the part that says

Emphasis can be used in the middle of a word:

EDIT: Just realized someone else brought this point up. Sorry for the additional post.


(Tobias Eigen) #7

@codinghorror has blogged about markdown at The Future of Markdown - a worthwhile read.

I think discourse is encouraging people to join the discussions at http://commonmark.org on improving markdown and making it more consistent for everyone, including discourse.

The commonmark spec CommonMark Spec actually describes “intraword emphasis” which is what @JazzyJosh is complaining does not work in discourse now, so maybe this is indeed a bug.

Personally I don’t see intraword emphasis as much of a priority, and I also don’t see the toolbar in the editor as much more than a guide. I always end up manually tweaking the markdown it generates… which I think is how it’s supposed to be used.


(Jeff Atwood) #8

Not a bug, by design. Intra-word emphasis is generally unwanted so we disable it.

Read this old blog post to learn why:


(cpradio) #9

It works if you use $.

Here is my test$unbelievable$but it works.

Works with italic too
Here is my test$unbelievable$but it works.

So it seems the boundary detection doesn’t apply to symbols.

Oooh, found a way to use a non-visible character to do it :smile:
test�bold�Iknow
test**bold**Iknow

Edit:
I only know this because we run into this “workaround” on our instance when people don’t properly surround their code blocks with backticks or indent them with 4 spaces.


(Sample Test) #10

You can also use HTML tags if you really need intra word.