Cannot reorder categories


(MagnumDopus) #1

Yes, I have set fixed category positions in the settings screen.

Then when I go to configure the order, no matter what order I set them to, no matter what numbers I assign, I can never save it.


(Jeff Atwood) #2

Can you repro this @techapj?


(MagnumDopus) #3

Just to be clear:
v1.7.0.beta8 +40

Take this screenshot for example, I have manually reversed the order yet the button is still greyed out.

I was able to apply the change, but cannot save it and my order is never actually altered. Sorry for the brief bug report at first.


(Arpit Jalan) #4

Yes I can repro this on latest Discourse version. Reorder categories modal is not even showing up on my development instance.

I think reorder-categories controller is broken after latest Ember upgrade. Can you have a look @eviltrout?


(MagnumDopus) #5

Odd that its not even showing up.

Quick question, I followed the instructions on how to set up discourse and ended up on a beta branch, I’d much prefer a stable non-beta, is there anyway to downgrade, or do a manual install for a specific version (I am a luddite apologies)


(Arpit Jalan) #6

See:

You want to be on stable branch.


(MagnumDopus) #7

See I’m confused, apparently I am already running tests-passed yet my version is clearly a beta version…

I changed the app.yml but when I do a git status it shows me as still on origin/master.


(Arpit Jalan) #8

In app.yml change

version: tests-passed

to

version: stable

Then run these commands:

git pull
./launcher rebuild app

I hope it’s clear now.


(MagnumDopus) #9

Apologies, I must be doing something incorrect. In app.yml I have changed it to both tests-passed and stable, saved the file and performed a pull.

However doing a git status still shows me on origin/mainline.

Doing a git branch -a shows I am on remotes/origin/HEAD -> origin/master.

I am sure I am doing something wrong, I’m sorry, but not sure exactly what.


(Arpit Jalan) #10

That status is for discourse_docker repository. Discourse version will be reflected in source of /latest page after your perform rebuild.


(MagnumDopus) #11

Ahh I see, again sorry, what is the differnece between tests-passed and stable? The how-to link provided earlier suggested test-passed. Just curious, I don’t see stable mentioned in that thread at all.

Looks like tests-passed kept me on the same version but stable fixed it for me, cheers!


(Jeff Atwood) #12

Note that you cannot downgrade versions however. So if you are on a new version, changing to an older one… won’t work.


(Robin Ward) #13

There was definitely an Ember regression here with SortableMixin which is no longer present. I’ve fixed it here:

https://github.com/discourse/discourse/commit/69ff0e48b4b50ad3df78dcb4f52915eef6850de9

Having said that, I’m not 100% sure that fixes the problem in the OP. I found the interface a little confusing, but when I reordered categories, I first had to hit “Fix Positions” before I could hit “Save Order” which was unintuitive. Once I did that though, things seemed to save?


(MagnumDopus) #14

Well I went from 1.7.0 Beta to 1.6.8, and am seeing no ill effects.

Would you suggest doing a clean install? I am not opposed to that, it is a brand new site so I would not be losing much, if you think it would be safer.


(Sam Saffron) #15

Yeah this dialog has always been a voodoo salad


(Jeff Atwood) #16