Cannot send any email with AWS SES

Hello, I’ve just installed Discourse on my Ubuntu server. It’s running on production and I can’t send any email from the Discourse. I created an IAM user on SES and entered my SES SMTP credentials correctly to Discourse’s config file. But I can’t get any emails from it. My SMTP works with telnet BTW. Can anyone help me to solve this problem? Thanks

1 Like

The problem I assume is related to Your SES account not having limits. Check it’s sending limits, it may still be in sandbox mode and You may have to request AWS support to raise your sending limits.

I’ve just sent 60k emails a few days ago with Sendy and it worked well. It’s not in sandbox mode and my domain is verified and also I’m using SES on cloud functions too and it works fine as well. I don’t think that problem is related to the SES limits.

Is Your sending domain the same as Your discourse domain? E.g. if You’re sending from then is the same verified at SES too?

My domains is and the forum’s domain is I’m still waiting for approval for the subdomain but AWS says once you verified your domain, all your subdomains should work fine. But is this could be the problem? The subdomain’s status is pending verification ATM.

1 Like

One workaround I can suggest is to change your notification email address in discourse.

You can use instead of which should get your emails delivered.

You can maybe check if amazon wants you to create additional DNS TXT records for the subdomain modification.

1 Like

You can use instead of which should get your emails delivered.

I tried to change it but couldn’t find anything on the internet. Do you know how to change it?

Yay! I changed the domain in the forum’s settings and it worked!
Dude, Thank you so much for your fast reply and support! Thank you!


Look at the very end of Your app.yml file

There will be something like sitesetting.notification_email
Uncomment that line then rebuild discourse. That should suffice.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.