Cannot type a colon character into Discourse posts when using Chrome on Windows 10

For some reason, only when posting to a Discourse forum, I cannot now include a colon (by typing or pasting on in). I cannot include a colon in the Discourse search bar either (not that this comes up very often). No error message, but any colon included is simply stripped out.

For posts at least, this is a bit of a problem given that colons, just like any other form of punctuation, form an important part of written English expression.

I assume this is a bug? Was it introduced with the latest Beta 10 update? Possibly something to do with Emojis?

You mean you can’t post a colon, like in before a list:

  • this
  • :
  • ;

Maybe the emoji autocomplete is confusing you? Can be dismissed by a space, is not invoked when the colon is adjacent to a letter and you can also use a line break afterwards.

1 Like

I can’t post a colon that looks like the character in the image below.
image

Hitting space before or after makes no difference (at least in my case), and a typing the colon immediately adjacent to a letter does not make it appear for me either.

*** EDIT - this seems to be a Chrome browser specific issue. In FireFox, the colon character works normally.

Is there anything known about Chrome that would trigger this issue specifically in Discourse web pages, but not in any others?

1 Like

As in, you can’t type a colon?

For me in Chrome, : works

:

  • :

→ :

Have you tried in incognito?

: works on mobile for me as well.

1 Like

Hi, I can neither paste in nor type in a colon into Discourse, using Chrome on Windows 10 PC. Using Chrome from my Android phone, or from another browser on my PC, no problem. The issue persists using Chrome incognito mode on PC.

1 Like

So you can on your PC on Firefox and on your phone in Chrome, which means that is a local problem on your personal Chrome install.

I’d try removing all extensions from the browser.

1 Like

: works for me on:

Google Chrome 79.0.3945.117 (Official Build) (64-bit) (cohort: Stable)
Revision 04f0a055010adab4484f7497fbfdbf312c307f1d-refs/branch-heads/3945@{#1019}
OS Windows 10 OS Version 1809 (Build 17763.973)

@Paul_King can you paste your versions from chrome://version/

4 Likes

All Extensions gone - : but issue persists. What is odd is that this same browser will accept a colon in any other web page that is not a Discourse web page - so it is specific to Discourse as well as to this browser install

1 Like

I can do it here and on a month-old forum. Tested using Chrome on both forums before and after the latest update.

79.0.3945.117 (Official Build) (64-bit)
79.0.3945.130 (Official Build) (64-bit)

Windows 10 OS Version 1903 (Build 18362.592)

3 Likes
Google Chrome 79.0.3945.117 (Official Build) (64-bit) (cohort: Stable)
Revision 04f0a055010adab4484f7497fbfdbf312c307f1d-refs/branch-heads/3945@{#1019}
OS Windows 10 OS Version 2004 (Build 19041.21)
JavaScript V8 7.9.317.32
Flash 32.0.0.321 C:\Users\paulk\AppData\Local\Google\Chrome\User Data\PepperFlash\32.0.0.321\pepflashplayer.dll
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.117 Safari/537.36
Command Line “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” --flag-switches-begin --enable-features=WebRtcHideLocalIpsWithMdns --flag-switches-end --enable-audio-service-sandbox
1 Like

Looks like this version of Windows is an Insider Preview Build? This is probably something that needs to be reported to the Windows OS team.

6 Likes

I guess so - crazily specific though: Only an issue under Chrome browser, and only when displaying a Discourse webpage.

(Note that I am replying via FireFox, so I can go :::::::!)

3 Likes

Further to this, opening this thread again in Chrome, all the colons I had typed above were not visible…making me wonder if this is a browser fonts issue, specifically exposed by whatever font Discourse uses for this forum theme

3 Likes

You can’t tell how specific it is because, unless you do a lot more testing, you don’t know the scope in any dimension of the current problem. It could affect all Chromium-based web browsers. You probably haven’t tried all characters. Etc.

1 Like

This would make sense!

If you type a bunch of colons in Chrome and post do they appear in Firefox?

Does overriding the font via devtools fix it?

1 Like

Testing all (US) keyboard accessible characters, my testing suggests only colon is affected.

From comments above, chrome browsers on other platforms are not affected

I just installed Chrome Edge browser to test, and can confirm it is similarly affected (colons not visible in Discourse, but visible on other web pages)::.

In Chrome now, and typing a bunch of (for me invisible) colons produces ::::::::::::

And it does look like overriding fonts in Devtools font-family temporarily fixes the problem, causing the above colons to appear (this is achieved only by deleting specifically the ‘Helvetica’ font reference, with no issues leaving either or both Arial’ and ‘Sans-serif’ in place )

Possibly for people who have Helvetica installed as a system font, this breaks something specific to the Discourse-in-Chrome context, but not for other browsers?

EDIT Confirming that uninstalling Helvetica as system font does resolve the problem in Chrome, and Chrome Edge browsers.
Not really a viable workaround, as like many people, I do use Helvetica in CAD and other graphical applications, and my formatting in existing documents will be messed up if another font was substituted.
Searching Google it seems both windows and Mac users are elsewhere reporting similar though not identical problems with Helvetica font in relation to Chrome on some websites.

4 Likes

It also appears to work in Microsoft Edge.

Browser

Version 79.0.309.71 (Official build) (64-bit)

OS

image

1 Like

Do you have Helvetica font installed?, and is this the Chrome based version of MS edge?

1 Like

Installed as part of the browser?

Yes, I’m using the stable version.

1 Like

I mean as a system font.
I found that as soon as I uninstalled the Helvetica system font, Chrome and Chrome-Edge behaved normally when displaying Discourse forums.

Other browsers were fine for me, with or without Helvetica installed as a system font. And other web pages under Chrome or Chrome-Edge were fine for me even with Helvetica installed as a system font.

1 Like