Quoting not working

On any browser, quoting seems to have become completely random - on some material it works, on others, no quote button is displayed. I can’t see any pattern in it. Using Discourse 2.6.0 beta5.

What am I missing? Is there some setting to adjust? But it just seems buggy.

1 Like

Hey Andrew, is this an issue you’re having with the Discourse Wordpress Plugin, or just with Discourse? If it’s just with Discourse, please change the category of your post to #support (it’s currently #support:wordpress).

As to the issue itself, could you talk us through some steps to reproduce the issue you’re having, for example:

  1. I select some text in a post I want to quote
  2. I don’t see the quote button appear…?
4 Likes

Indeed, exactly that. Except that you can quote some parts of some posts and not at all others. At this point I am unable to see a pattern in it.

I can see that in Firefox I can sometimes see the Quote button flash and then it very quickly disappears.

1 Like

More testing shows that it is the case that I cant quote text that occurs after a quote. That can’t be desired behaviour, can it? Text before a quote I can quote.

1 Like

Ah, Ignore all this. It’s a poster who puts in manual line breaks (hard to see at first) and when you select what looks like a paragraph, quoting does not work. So it’s not really an issue. I was wondering why this suddenly started happening - it’s just posts from one erratic user. Most likely posts submitted by email that has wrapped the lines.

Consider the case closed.

2 Likes

I still don’t see why quoting should break in this case…

1 Like

Can you provide a post here that cannot be quoted?

I have tried to replicate this here using what I think people are saying below, but I can’t replicate it here.

This is some text

this 
is 
some
code

and more text

This is a line that ends with a <p>

and another line.

1 Like

I’ve been having issues with this on https://caddy.community for the past while.

It seems to happen when the selection crosses the boundary of HTML elements.

For example, if I select text that is totally contained within its own <p> with no <code> elements, it works fine, but as soon as I start also selecting the <code> bit, it doesn’t show the Quote button.

If I select a whole header (see any help post on the forums, which use a template for OP, with headers) then quote appears, but if selecting a header line plus the next line which is a <p>, then there’s no quote.

I’m not certain this is the cause, but it seems to be. This all used to work before, I could select anything I wanted to quote it. It’s been broken for idk, maybe a month? Hard to say when it started being a problem. We’re using 2.6.0.beta5 right now.

Firefox on Linux, Android and Windows.

3 Likes

I notice the issue also happens across headers, line breaks, and code blocks. Using Chrome on Linux.

1 Like

Example in action on a recent post on the Caddy community:

Screen Shot 2020-11-17 at 10.14.11 am

Quoting works within a code boundary (but only if carefully selected)

Screen Shot 2020-11-17 at 10.14.36 am

Quoting does not work if you simply double-click select the code text

Screen Shot 2020-11-17 at 10.15.00 am

Quoting works if you double-click non-code text

Screen Shot 2020-11-17 at 10.15.18 am

Quoting does not work if you select over the code/normal text boundary

2 Likes

Yes, I see the same. Now that others have seen it, should we raise it as a defect?

1 Like

If you can’t replicate it here then it’s an issue with the site theme.

2 Likes

It’s not theme related. I tried several themes. I don’t know how to show this here, but as mentioned, some of my users submit by email, and email clients do all sorts of unmanageable things with line wrapping and hard returns. On the particular page where I noticed this, what looks like a coherent paragraph is a set of lines separated by
in the HTML. You can quote the lines, but not the whole paragraph. Here is an attempt to show this:

This just a test. Seems you can't quote whole
paragraphs where lines
are separated by br tags, like
this.

[Now having posted this, it works on this Discourse Meta site, but not on my instance, 2.6.0.beta5 latest update, standard Dark theme.]

2 Likes

Have you tried in safe mode?

2 Likes

Issue persists identically in safe mode.

1 Like

How do I move this thread to a bug report? Something is definitely broken.

Unless you can repro it here in a post, we will not accept this as a bug.

Here’s text with code inside, let me try quoting it…

Yes that quotes fine.

1 Like

So what version of Discourse is this site running?

This is a bit subtle because it is clearly defective on my site, else I would not be raising this. Of course you need to be able to duplicate, but …

1 Like

The latest version. You can view source and look for the generator tag near the top.

Your problem persists in safe mode?

Edit: I thought you’d said so, but it’s still the best explanation. You might do a rebuild if you haven’t lately. That very often fixes things.

1 Like

Yes, as mentioned already above, sorry to say safe mode does not make any difference.

2 Likes