Can't access a group page anymore


(Tom) #1

I’m not sure how this happened, so I’m sorry but I have no repro for this issue.

All I know is that there’s no longer a “groups” tab on the /admin/ page (iirc, there used to be one) and going to the /groups pages and then clicking on 1 specific group, the screen is just white. No errors, nothing at all. For any other group the page loads just fine and I’m able to edit the group.

It’s my own forums so yes I’m an admin (also tried with a backup admin account, still the same issue).

So my question is: how can I manually (through ssh or something similar) delete a group to hopefully fix this issue?

I’ve tried restoring a backup and also rebuilding the current site, nothing seems to work sadly.

screenshot of the “white” group page: (url: https://forum.devtesting.pizza/groups/hide)

screenshot of the /groups/hide.json page:

Edit: trying again in safe-mode does not solve the issue.


(Tom) #2

I’ve deleted the group through the rails console, using:

Group.find_by_id(52).destroy!()

Still don’t see the Groups page in the /admin/ page. Was this page removed in a recent update?

Also, re-creating a group with the same name hide breaks things again. I guess that name is just cursed…


(Simon Cossar) #3

Yes, it was moved. See: Admin Group Setting Missing


(Tom) #4

Alrigh thanks for that!


(Jeff Atwood) #5