Can't delete accounts


#1

Hi everyone,

I can’t seem to delete accounts. Every time I try to delete an account I get a message saying that accounts can only be deleted when there are no posts linked with the account anymore:

(Message is in Dutch)

However, ther user doesn’t have any posts to their name any more:

(‘Gemaakte berichten’ is Dutch for ‘posts created’)
IMG_0217

The log doesn’t show any errors, but I still can’t delete the user. So for now we’ve anonymised all users who want their account deleted, but it would be nice if we could indeed delete the accounts completely.

Could this have to do with the fact that the users have private messages in their mailboxes? I can’t seem to delete those, just archive them.

Thanks in advance!


(Sam Saffron) #2

Maybe PMs, look in the user messages?


#3

Hi @sam,

The users indeed do have private messages in their mailboxes. But I can’t seem to delete those - just archive them. Am I missing something obvious? :slight_smile:

Thanks!


(Tobias Eigen) #4

Do you see an admin wrench? That is where you delete messages and posts as admin. Otherwise they cannot be deleted.


(Neil Lalonde) #5

Which version of Discourse are you on? On the current version, posts in private messages will show in the total post count in admin, and can be deleted either by using the “Delete all posts” button or the “Delete User” button.


#7

I’ve got admin-view of the profile in front of me. Under activity it says there are 0 posts created but there are private topics created due to the fact that this user sent and received internal messages. Clicking on the orange ‘remove user’ button generates an error.

I’m sure this is related to the fact that the user still has a number of private messages in their sent/received mailbox.

When I ‘login as user’ I can’t delete those messages, as there is no option to do so. I can however click ‘archive’, but all that does is move the messages to the ‘archive’ mailbox.

When I login as the user and go to account, there’s a button ‘Delete my account’. When I click that, I get a pop-up after some waiting, that says ‘please contact a staff member if you wish your account to be deleted.’

I’m running version v.2.1.0.beta6 +46. The smiley says I’m up to date.

If you have any more suggestions, then please! :slight_smile:


#8

Hmm, interesting. I’ve anonymised the user, and when I now click on ‘download all my data’, I get a CSV which indeed contains a lot of posts. But the post count on the anonymised stats page says the user has written 0 posts.


(Neil Lalonde) #9

Did you try deleting a post in the private messages as your admin user? Don’t login as the user.

26%20AM

Is the delete option there? Does it work for these “0 posts created” users?

I can easily verify that posts in private messages are being counted in the admin UI in the “Posts Created” value.


#10

Hi @neil, I’ve not gone in to check if I can delete one message. However, I was hoping I wouldn’t have to delete all messages individually as we have a few users who have been very active… :wink:

The ‘Posts Created’ count for the user is 0, checked in the admin UI. See also the second image in my opening post. (‘Gemaakte berichten’ is the Dutch translation of ‘Posts Created’).


(Neil Lalonde) #11

Ok can you try it on only one such post? Trying to figure out what’s so special about these posts. Being in a private message isn’t special. We need more info.


#12

Ok, that seems to work - I can indeed delete individual messages.

That is, they’re turning red.

@neil I don’t mind running a script on the database that deletes the messages if needed - but I’m not sure how wise an idea that is.