Can't detect domain

Howdy! I tried to install Discourse on my Raspberry Pi 4B 2GB ram, but I did not succeed.

I am getting the error:

WARNING: Port 443 of computer does not appear to be accessible using hostname:
WARNING: Connection to (port 80) also fails.

I made sure that:

  • All needed ports are forwarded. (80 and 433) **
  • The Raspberry Pi is up to date with all packages.
  • It is able to reach the internet.
  • Cloudflare has all of the DNS records set up, **²

** I had already talked to my ISP about port forwarding and if it is okay.
**² These are the following records on CF:
(A) - mydomain.cоm - - DNS only - Auto
(A) - subdomain - - DNS only - Auto
(HTTPS) - subdomain - 0 - DNS only - Auto

Any other info:

I’m in a rush and can’t find much more info than this.
(Domains and IPs in the DNS / Errors are dummy IPs. These are not actual domains / IP adresses.)


You’re using cloudflare, right? Make sure for setup, the DNS record is set to “DNS Only” (Grey cloud)

After setup, you can make it “Proxied” (orange cloud) again.

Did you do the port forward from your router to the raspberry pi on port 443?

Try pinging your intended domain from command prompt. The IP address that it returns should be your servers public IP.

  • Did you allow the ports in the firewall of your Raspberry Pi?
  • Have you tried using another network like your phone’s cellular data to access the domain?
    Your router may not support NAT loopback so you can’t access the domain from your internal network.

Yup. It is on DNS only. I can’t get trough the setup though.

Yes. It is forwarded on 80 and 443.

Yes my public IP replies.

I do not remember installing any firewalls and when I used any other webserver, it worked.
The problem is I can’t even setup Discourse. And, no my router does not support NAT loopback so I do test it with my phones cell.

1 Like