Port 443 isn't accessible via hostname

I’ve recently decided to try to install Discourse. Upon getting everything in the folder on Ubuntu 20.4, I’m getting a “Port 443 isn’t accessible via hostname” error. Trying to connect internally and externally won’t work at all.

I’ve done a LOT of searching around. I’ve removed proxies via CloudFlare and just flat out reinstalled it multiple times, changing the sub domains, even using the root domain at one point. Nothing has worked.

I have confirmed every time that the domain IS pointing to the Ubuntu server, there is not a firewall blocking traffic, the port is open, and everything is set up correctly. This domain has worked for the past 3 months but suddenly stopped when migrating to Discourse, which leads me to believe it might be user error. But everything I have found online doesn’t seem to help rectify the issue, nor have my own troubleshooting steps helped in this scenario.

1 Like

Make sure cloudflare is dns only. Gray cloud. Orange cloud causes the issue you describe.

1 Like

That was one of the first things I managed to do. Both domains I tried I set to DNS only and pinged to make sure it was only going through to the IP and not proxied through CF.

1 Like

pinging the domain name is sending a time out.


is the IP address correct ?

I’m suspecting a firewall issue here. Which hosting provider are you using for discourse? Is the server using UFW or an external firewall that’s blocking inbound connections?

That juat means ICMP is being dropped. It doesn’t necessarily mean theres a DNS issue, but does suggest a firewall of some form is being used.

@awexx - are you trying to host this on a charter broadband connection? - is an old Charter IP range for their cable network. They shouldn’t block :443, but their AUP does prohibit it and I have previously heard of customers having their access restricted or address relocated when the behavior has been detected.

Also look at the network configuration of wherever you’re virtualizing the Ubuntu instance, is it set to use the host network, or bridge? Which hypervisor are you using?


Yes, I am using a Charter Broadband connection. I’ve ironically enough had 0 issues trying to host anything else via this network, 443 and 80 have opened fine and operated fine outside of my network.

This is hosted on a local server on Ubuntu 20.4. It’s set to use the host network.

Checking my router port forwarding, everything seems fine. Actually, now that I think of it, it’d be the router firewall wouldn’t it?

It’s probably blocking pings for Gavin; I just pinged again and it’s working.

If you’re on the same network as the server then the loopback, connection would explain why you can ping it, and he can’t.

Either way though, this doesn’t sound like a Discourse issue, so I’m not sure we can really help you.

The setup guide calls for a cloud server because it’s a simple and straightforward way to get up and running. If you want to try to use your own network environment in an area where the network provider actively prohibits the hosting of servers, then I’m afraid it probably goes beyond the scope of the free support we provide here and is going to be on you to figure out.


I understand, I was planning on getting a cloud server anyway for Discourse and also placing my other resources elsewhere if this didn’t work.

Thanks anyway :slight_smile:

1 Like