Can't send test email with Amazon SES


(Blackening999) #1

Hello!

I’ve got some issues on receiving the email. Checked all instructions but it isn’t work.
I’m using next configs:

config.action_mailer.smtp_settings = {
   address: 'email-smtp.us-east-1.amazonaws.com',
   authentication: :login,
   password: 'PWD',
   user_name: 'USRNAME',
   enable_starttls_auto: true,
   port: 587
 }

Got this error when trying to test it.
“There was a problem sending the test email. Please double-check your mail settings, verify that your host is not blocking mail connections, and try again.”

My app.yml discourse’s configs:


Troubleshooting email on a new Discourse install
Created overwritten when editing first post
(Kane York) #2

Add DISCOURSE_SMTP_AUTHENTICATION: "login"


(Blackening999) #3

The same issue.
I’ve added this row:

 DISCOURSE_SMTP_ENABLE_START_TLS: true
 DISCOURSE_SMTP_AUTHENTICATION: "login"

and then ran ./launcher rebuild app

Also, when I’m trying to test it via telnet:

got this…


(Blackening999) #4

fixed issue.

Thanks for suggestion with SMTP Authentication config option.

I have created user in SES and everything working now


(Régis Hanol) #5