Can't set download remote images


(Danpiel) #1

Hello, got issue with option “Download remote images”, I set this option, reload admin page, the option stays unchecked. More details follow:

What I have:

Fresh Discourse install 2.1.0 with imported posts and users from IPBoard3, the import was successful, no issues there. The forum uses valid Let’s Encrypt certificate and force_https option.

Two plugins, which I disabled, but it didn’t helped.

The issue itself and what I tried:

In admin panel the option is selectable, but upon reload it’s kinda not saved, the miniprofiler shows that query was successful.

Tried rake posts:rebake, no changes
No admin actions to download the images (option to suppress the output of downloads are disabled) are logged
No stalled queues in sidekiq, no errors in logs.

Seems like something blocks this functionality, where to dig to fix this.


(Rafael dos Santos Silva) #2

How much free disk space you have?


(Danpiel) #3

890 GB of 1TB, dedicated disks, separate lvm vg, separate partition.


(Régis Hanol) #4

What does this command returns (inside the container)

df -P /var/www/discourse/public/uploads | tail -1 | tr -s ' ' | cut -d ' ' -f 5

Also, what is the value of the “download remote images threshold” site setting?

Are there any logs about that setting being automatically disabled?


(Danpiel) #5

The output is 10%

The full

Filesystem                           Size  Used Avail Use% Mounted on
/dev/mapper/ag02-container--storage  932G   90G  840G  10% /
tmpfs                                 64M     0   64M   0% /dev
tmpfs                                7.9G     0  7.9G   0% /sys/fs/cgroup
/dev/mapper/ag02-container--storage  932G   90G  840G  10% /shared
shm                                  512M  8.0K  512M   1% /dev/shm
tmpfs                                7.9G     0  7.9G   0% /proc/scsi
tmpfs                                7.9G     0  7.9G   0% /sys/firmware

Download threshold is default 10%, so it would be nearly 93Gb

Will recheck logs


(Danpiel) #6

Nothing in logs, but I found that reloading admin page with option multiple times, sometimes shows the checkmark in the box, sometimes checkmark is missing.

Seems I found the issue, the record in database was duplicate

 id |              name               | data_type | value |         created_at         |         updated_at
----+---------------------------------+-----------+-------+----------------------------+----------------------------
 46 | download_remote_images_to_local |         5 | t     | 2018-05-28 21:27:26.542915 | 2018-06-05 10:40:51.894279
 47 | download_remote_images_to_local |         5 | f     | 2018-05-28 21:27:26.543519 | 2018-06-05 10:40:49.163287
(2 rows)

Removed both records, reapplied option from admin panel, new proper record applied.


(Danpiel) #7

@zogstrip @Falco thank you for your help and pointing in right direction.