Cant setting SLL (Let's Encrypt) for Discourse


(Hoang Nam) #1

Cant setting SLL (Let’s Encrypt) for Discourse setting SSL on Setting up Let’s Encrypt

But It error:

FAILED
--------------------
    Pups::ExecError: cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --upgrade --auto-upgrade failed with return #<Process::Status: pid 3354 exit 1>
    Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
    exec failed with the params {"cmd"=>["cd /root && git clone https://github.com/Neilpang/acme.sh.git && cd /root/acme.sh && git reset --hard e5244cf3c04a5cad274d5a0be31ce80c336be388", "touch /var/spool/cron/crontabs/root", "install -d -m 0755 -g root -o root $LETSENCRYPT_DIR", "cd /root/acme.sh && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./acme.sh --install --log \"${LETSENCRYPT_DIR}/acme.sh.log\"", "cd /root/acme.sh && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./acme.sh --upgrade --auto-upgrade"]}
    ffd7032014ec2a1936b71deb1971516af9bf8a3951935548df05a13158eb2369

Please help me.


(Jay Pfaffman) #2

Please say more about what you did. Has it ever worked? How did you enable it?


(Hoang Nam) #3

Oh!. i fixed…

Before:
I config like Setting up Let's Encrypt and run
./laucher rebulid app but error.

Affter:
I run
cd /root/acme.sh
git clone GitHub - Neilpang/acme.sh: A pure Unix shell script implementing ACME client protocol
./laucher rebulid app
It is successfully.

So happy!


(Jeff Atwood) #4

Hmm @tgxworld is this related to the other problem report with this today?


(Joshua Rosenfeld) #5

This topic was automatically closed after 5 hours. New replies are no longer allowed.


(Alan Tan) #6

Yup I bumped the version of acme.sh again.