Cant setting SLL (Let's Encrypt) for Discourse

(Hoang Nam) #1

Cant setting SLL (Let’s Encrypt) for Discourse setting SSL on Setting up Let’s Encrypt

But It error:

    Pups::ExecError: cd /root/ && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./ --upgrade --auto-upgrade failed with return #<Process::Status: pid 3354 exit 1>
    Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
    exec failed with the params {"cmd"=>["cd /root && git clone && cd /root/ && git reset --hard e5244cf3c04a5cad274d5a0be31ce80c336be388", "touch /var/spool/cron/crontabs/root", "install -d -m 0755 -g root -o root $LETSENCRYPT_DIR", "cd /root/ && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./ --install --log \"${LETSENCRYPT_DIR}/\"", "cd /root/ && LE_WORKING_DIR=\"${LETSENCRYPT_DIR}\" ./ --upgrade --auto-upgrade"]}

Please help me.

(Jay Pfaffman) #2

Please say more about what you did. Has it ever worked? How did you enable it?

(Hoang Nam) #3

Oh!. i fixed…

I config like Setting up Let's Encrypt and run
./laucher rebulid app but error.

I run
cd /root/
git clone GitHub - Neilpang/ A pure Unix shell script implementing ACME client protocol
./laucher rebulid app
It is successfully.

So happy!

(Jeff Atwood) #4

Hmm @tgxworld is this related to the other problem report with this today?

(Joshua Rosenfeld) #5

This topic was automatically closed after 5 hours. New replies are no longer allowed.

(Alan Tan) #6

Yup I bumped the version of again.