Can't upload new images or emoji

I’m having a similar issue to Emoji upload fails - regression?


  1. uploaded a whole lot of emoji to a new Discourse instance
  2. started getting 400 errors
  3. deleted some emoji wondering if I didn’t really need 'em
  4. now all the image uploads fail (the message is “Sorry, there was an error uploading that file. Please try again.”)

Upgrading to the latest discourse listed in /admin (e8efdd6) helped for a few more uploads but it stopped working again relatively quickly.

Any ideas on what to do? Is this a rate limiting thing, and if so why am I getting a 400 instead of a 429?


update: I was able to get the ones I wanted uploaded by rebuilding the image several times. That really feels like a rate limiting issue to me… is it? I’d like to get to the bottom of this still so I know what to do in the future.


To confirm, 400 errors? Not 403, 404, or 429?


Yep, 400s

(padding padding padding yay)

What’s strange here is that 400 is a client error. Uploading emoji to a Discourse instance shouldn’t then impact your client. So after you uploaded emoji, then deleted some, you can’t upload normal images to a post?

Have you tried a different device? Are you the only user experiencing the issue, or are there others?

As I said in my update, I was able to get around this by rebuilding the docker container a couple of times. I don’t think other people have tried to upload images; I do not know if they are blocked. I could not upload normal images while this was happening.

Right, but as you say in your first post, rate limits should give a 429 issue. At the moment I’m very hesitate to say this is a bug given a single report - if we had a rate limit issue for image uploads we’d be hearing about it.

If this occurs again, please confirm if it is device specific or not, so we can dig further.

1 Like