Emoji upload fails - regression?

Hi all,

I tried to upload a larger patch of emoji into my instance. At first, everything worked fine. Then, I increased the number of files I can upload to 20, and started dropping emoji onto the customize page. I had a few errors here and there, but after an upload of around 120 images, no further upload was possible. Plus, the emoji picker did only show 3.

Deleting all emoji made things worse: now I cannot upload a single emoji, symptoms like this:

Can this be a regression of this? Or another problem? I even tried rebuilding the whole container to no avail.

2 Likes

any ideas @zogstrip?

2 Likes

Any chances you could invite me (regis.hanol@discourse.org) as admin on your instance so that I can have a look :mag: ?

5 Likes

Sent you that email… Funny, I was able to upload around 60 emoji before it started spitting out error messages again… Any hints would be appreciated.

1 Like

Turned out, if you drag & drop 20 emojis at once, you’ll get rate limited by NGINX pretty soon…

I changed it so that we now upload emojis sequentially :wink:

5 Likes

Great, thanks! I will check this out on the next occasion and let you know!

Hm. Looks better now, I was able to upload most of them in batches of 10-15 each. But now it coughs up the same error. Nginx logs show an error 400:

[14/Feb/2019:11:49:51 +0000] "www.mysite.tld" 46.5.158.250 "POST /admin/customize/emojis.json?client_id=…3a4432c24effb&authenticity_token=…Bgz73aiLveyLUDkslPywsIKzrqb40O7Rul7h1iNAb6HVfjqO7wv1tVSiJnT4nL8wtBtvMvQ%3D%3D HTTP/2.0"
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.3 Safari/605.1.15" "-" 400 229 "https://www.mysite.tld/admin/customize/emojis" - 0.000 "-"

(did not even know that there was an error 400…)

Did you update discourse to pull in the changes? Are you on tests-passed?

1 Like

Yeah, I’m on tests-passed, missing only todays commits:

@daniel can you try to reproduce?

2 Likes

@udan11 can you add to your list to try to reproduce this issue and close this topic if you can’t anymore?

1 Like

I managed to upload emojis without any problem. This bug is no longer reproducible.

4 Likes