Change login button action


(bastian meissner) #1

Hello everyone,

I am trying to change the login button to redirect me to my saml authenticator instead of showing the modal where you would normally have the username and password text fields.

Is there any way to accomplish that?


(Joe Buhlig) #2

Maybe I simply don’t follow how a SAML authenticator works but wouldn’t you want to set up the SSO settings for this to work? That would set up the redirects to external login providers for you.


#3

I’ll chip in because I’m working on the same solution. We don’t want external users in the system. We’re building an Academic community based mailman replacement and Discourse can basically do everything we want ánd more. We can offer the errr, “traditional” people a way to just continue using mail and users that want to will be able to use this very fresh and clean web interface.

The problem we’re running into is that SSO itself doesn’t meet our needs: It doesn’t implement OAuth2 in a way that we can use it out of the box, nor does it do SAML. This forum needs to be 100% behind bars because the material is under a Non-Disclosure Agreement.

We’re fronting it NetIQ Access Manager, which consists of two components, an IdP and an Access Gateway. This IdP does what every single one of them does, and the Access Gateway acts as a reverse proxy where we can define per reverse proxy what kind of protection is needed. If a resource that requires authentication (and the correct authorization) is requested, Access Manager will redirect the client to a login page. After authenticating, we’d like for our Discourse setup to “simply” authenticate the user immediately as well. This makes direct URLs very happy as well.

Now if SSO would support trivial SAML implementations then sure, we’d use that. But it doesn’t as far as I can see. We can’t use anything our own custom provider. We simply can’t use a cloud service or facebook or whatever, our users would run away and rightfully so.


(Sam Saffron) #4

If you only have 1 auth method, it should automatically redirect. Disable local logins.


(bastian meissner) #5

that fixed it; thank you :slight_smile: