Changing default email digest frequency not applying retroactively

When changing the default email digest frequency and confirming to make the changes to accounts retroactively, the changes do not take effect for all accounts. Clicking Yes to the following question does not have the expected behavior: "Would you like to apply this change historically? This will change preferences for n existing users.

While some accounts may update to the desired frequency, in my experience many do not. Possibly this has something to do with having selected “Disable summary emails for all users.” at one point. Users who’s frequency is not updated are users with Summary emails not enabled within their user preferences. They did not make these selections themselves as these users were created as part of SSO with Wordpress and these accounts have never been logged into.

1 Like

I tested this on my local dev site. I was getting the same result as you are reporting. When selecting the “apply changes historically” option, the preferences of only a few users were updated.

I just pulled the latest Discourse code to my dev site and am now finding that the options for all users on the site are correctly updated when I change the default email digest frequency site setting and select the “apply changes historically” option. I am not sure if this is due to an update in the Discourse code, or if there is some other issue that is causing the results of updating this setting to be inconsistent.

2 Likes

Thanks for confirming. I’m running 2.5.0.beta2. Hopefully the next release will straighten this out.

1 Like

It is fixed now. Let me know if you still have any issues.

3 Likes

Thanks. Appreciate it.

This topic was automatically closed after 12 days. New replies are no longer allowed.