Changing host for Wordpress, lost connection to Discourse (curl 6 error)

Hi! I checked old posts closed to my problem but didn’t find the solution, so here I am.

I have a WP site (hosted on server A) connected to a Discourse forum (on server B) and acting as a SSO provider for said forum.

I recently changed host for WP (so, to server C —new hosting company) and DNS provider altogether, from Google to Gandi, scrupulously recreating the DNS settings (@ on the new IP, www as a CNAME, and forum on its unchanged IP) ; the forum staying on the server B.

Now WP says connection is broken and I get a curl 6 error (unable to resolve host; unknown error) when trying to publish (I also get a “there’s no admin with xyz@mydomain.net address” but I figure it’s kinda normal if it’s not connected).

Any clue or idea where to look? I already contacted the new provider to check any firewall setting but they say it’s all clear and I probably should check with the plugin devs.
TIA!

1 Like

Does an nslookup from server C’s command line return the correct IP address of server B?

2 Likes

Yes, it does (he said using at least 20 characters :slight_smile: )

1 Like

Darn :slight_smile: And the reverse? I’m no expert at SSO, but I believe server B needs to do a callback to server C? If it still has server A’s IP address somewhere that might fail.

1 Like

It does, too (still using at least 20 chars)

1 Like

Have you tried uninstalling the WP discourse plug-in, and then reinstalling it? I found that the plug-in doesn’t handle server changes without doing that in the past.

1 Like

Hey Romain, there could be a few different reasons.

The reason we recently added logging infrastructure to the plugin is to directly diagnose these kind of issues. We’ll be adding logging to the connection functionality soon, however it’s only currently active in the publication functionality.

A connection issue in the publication logs are unlikely to tell us anything useful. Nevertheless, you did mention an attempt to publish, so please first check the “Logs” admin panel in the WP Discourse plugin. You can share a specific line from the log, or share the whole log with me via PM. I’d also recommend issuing new API credentials in your Discourse and applying them in the plugin to ensure that’s not the cause.

Aside from that, while I wouldn’t want to turn this into a tit-for-tat with your hosts, an inability to cURL a domain, suggests an environmental issue, not a plugin issue. If you search for similar errors here you’ll find that @simon kindly helping various folks diagnose what are effectively environmental issues. For example (including some possible diagnostic tools) see

I’d recommend you press your hosting provider a bit more, asking them why there’d be an inability to make a cURL request to a domain. If they have some more specific reason to think it’s an issue with the WP Discourse plugin, and not say, an incorrect cURL version on the server (which on the face of it is more likely), they’re welcome to post here, or even pm me, and I’d be happy to look into it further with them.

2 Likes

@jtbayly I tried uninstalling/reinstalling to no avail.

@angus you might be onto something, when installing the TLS test plugin, I get an error that looks like updating curl would be a possible solution.

However, since the hosting company’s answer about updating curl is this: "The version of cURL installed here is the latest official version in the CentOS repository.
That is why we are using this version and not the newest available in the official developer’s website.

CentOS are very cautious of pushing new versions in the official repository because they are making a lot of tests on the software before release it to make sure it’s stable in all occasions.
Once the new version is released on the official CentOS repository it will be updated within us as well.", I guess that won’t go any further and I just have to switch hosts again.

1 Like

Before making the switch, perhaps point out to them that not supporting TLS 1.2 is going to cause issues with supporting a few Wordpress plugins, and has some security issues in-of-itself. Still might be worth pursing a bit further.

In any event, yes that seems to be your issue.

1 Like

I’ll try since “I cannot tolerate not trying” (M. Jordan, philosopher :wink: ) but their minds seem pretty made on this one.
Old host is using 7.68 on Ubuntu.

Thanks for your help!

3 Likes