Chat fails to show images generated via Discourse AI


On forumside I can use webp images, but if I try upload such one to chat I see it, but closing that channel and re-entry… that image has vanishes.

If I copy url (S3, not local) of such image from a topic and paste it on chat that images shows just fine.

There is one and only one reason why I would like to use that extension — Dall-E via Discourse AI creates such ones…

I’ve allowed webp on settings, but I guess the issue is a bit deeper.



I just tried it in channels and threads, by direct upload or copy/paste and couldn’t repro this. Can you still repro? If yes can you tell us more? Browser? Maybe give me the image you are trying.

On my own forum the issue still exists. And that point I started this topic it didn’t work in either. Here I never tried because I tried avoid unnecessary noise :woozy_face:

I did upgrading yesterday, so I don’t know if something has happened after that. I’m using DiscourseHub and Safari, iPad/iPhone with newest OS.

For example this image:

Okei, it must be an issue of AI-generated images. Every image generated via Discourse AI, both Stability and Dall-E, fails when uploaded to chat. No matter are those jpeg or webp.

(I edited the title)

I’ve narrowed it more. It happends only when used iPad or iPhone. Will apple-OS do something to those images when saved from PM-chat with AI? And why it happends only in chat, but in topics and 3rd party sites (e.g. WordPress) those images are just fine :thinking:

Hey @Jagster is it still happening? I don’t have a phone handy, but just wanted to check whether this had been fixed in the past 6 months.

1 Like

No, it is still there. DallE generates jpegs again, that has been fixed somehow somewhere. But chat can’t show webp-images when closing and open again that channel.

1 Like

I tried to reproduce and couldn’t. Can you open a chat DM with me and send webp images?

1 Like

Can you test again, I fixed an issue yesterday with this.

Splendid. Now it works on my end. Thanks!