Chat problem on mobile devices with 3.1.0beta5


my users and also myself noticed that with mobile devices (Android and iOS) the chat is more or less broken. Because when clicking into the text box the soft keyboard appears. But the screen is not adjusted and it is not possible to see what you type. Also Return does not send the text and the send button is also gone.

Before the upgrade to 3.1.0beta5 everything was okay according to the users (personally I do not use Chat very often).


Are you seeing this in safe mode as well?

I’ve just had a quick run-through I can’t repro this here on Meta or on my test site?

1 Like

Good point. No. If I deactivate the first option (themes and theme components) I see the composer window and everything else. So it seems to be a theme component which is interfering (I only changed colors for our theme).

1 Like

Did you end up finding the issue here? I wanted to try on your forum but seems like you disabled chat. If you re-enable it I can help you understand the issue.

1 Like

Thank you for coming back to this. :slight_smile:

There was/is a problem with the image slider we use. We were able to get around the problem by putting this into the mobile CSS:

.has-full-page-chat #captioned-gallery {
    display: none;

Chat works again, but I still have another issue, which also seems to be related to the image slider:

Every time the image slides, the problem can (only can) occur.

For sure, this is a problem for our forum only because the slider is non standard. But something changed with 3.1.0beta5 which was not there before.

Btw Chat is only available for TL1 and up, so it is not visible when visiting the forum and not logging in.

1 Like

Weird, I can’t repro so far but similar to what you did you can probably have this css: #captioned-gallery {
    display: none;

If I could repro, I would probably try to play with z-index of #captioned-galery too, maybe z-index: 1.

The flicker bug does not only appear when the composer is opened. It happens everywhere, but not every time. Another example:

Only seconds ago it also flickered in the lower part of the screen where the “Gurtband” thread is visible.

I will try that. It is not easy to debug, as it only shows this on mobile devices.

Did something change from 3.1.0beta4 to 5? It worked until 4…

I tried z-index, also inside the captioned-gallery container on figure.sidemount-slider. No luck. But I cannot say for sure if my Android phone was not using old cached data inside the app and also the Chrome App for the forum.

Im fixing things on chat with android today, will have a look on your site and see if I can repro something.

Possibly, a lot of things :sweat_smile:


:+1: If you like, get an account. I can promote you to that level you need to have to see Chat.

If I do not need to hide the slider on mobile devices in chat, that would be great, too. But nobody noticed (or said something). The flicker thing is more of a problem…

Sadly I don’t repro anything so far :confused:


This is looks like a chrome bug: 1397578 - chromium - An open-source project to help move the web forward. - Monorail I also have this kind of issues unfortunately…

1 Like

It is hard to reproduce. The chat bug is gone by hiding the slider with the css statement from above.

And the flicker bug is there for mobile devices - maybe only for Android devices? Because:

Interesting! If that is the same, it only affects Android devices, correct?

Hm so you did not manage to get it solved? Did it also came up after upgrading to 3.1.0beta5 oder did you experience it also earlier? Do you also have something like our header image slider?

I think almost a year now chrome is not too good for me. Sometimes chrome updates seems fix some of these but another update results same bug. I didn’t notice the carousel issue but in the past it was. Now where I notice this sometimes, the icons missing or flickers and seems the elements falls apart flickers etc… A great way to investigate it is Discourse related is try to reproduce such things on other (not Discourse) sites. I think it was a similar kind of issue: Weird issue with topic posts on mobile

1 Like