Comments not being embedded in wordpress plugin


(@SenpaiMass) #1

First of all thanks for this awesome plugin.
Currently i have set my wp-discourse permission as follows

Still not being able to get the discourse comments embeded on the blog.


(Jay Pfaffman) #2

Do you have your blog’s domain set in /admin/customize/embedding?

I can’t quite tell if it’s the site’s domain name (e.g., http://blog.yourblog.com/) or the reverse DNS name of the blog’s host–which you could get like this:

dig -x `dig +short literatecomputing.com`

(@SenpaiMass) #3

Yes i have my blog domain on /customize/embedding

Here is my community
https://animeforums.me
Blog - http://blog.animeforums.me


div id='discourse-comments'></div>

<script type="text/javascript">
  DiscourseEmbed = { discourseUrl: 'https://animeforums.me/',
                     discourseEmbedUrl: 'REPLACE_ME' };

  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>

Should i need to add the above code in every post? Or in comments.php?


(Steven Greco) #4

You do not need to setup the embedded functionality. The plugin handles adding that code into your WordPress posts.

Really the best way to test is if you have the correct api key entered into the plugin. To test would be to see if the category drop down list populates within the plugin settings.

Do the categories show up?


(@SenpaiMass) #5

Okay i removed the Embedding from admin/customize
As of now the published categories dropdown menu at wordpress plugin-discourse is blank not showing anything.

Edit : It was showing some time back dont know what the error is. I generated a new master API and added to the plugin to be sure.


(Jay Pfaffman) #6

Oops. I forgot that the Wordpress plug-in used API keys. I configured Ghost more recently. Sorry about that.


(Steven Greco) #7

Also make sure the username for posting you have in the plugin settings is an admin account. You can use “system” as well.


(@SenpaiMass) #8

I have the settings done as per said above. If possible i can pm the admin details to check out why comments are not being displayed. Help would be highly appreciated :slightly_smiling:

Edit:

Got it working, thanks for the help guys.


(Tropnevad) #9

@Alankrit_Choudh just a heads up it seems that all the links to your blog in discourse dont seem to be working as they dont redirect directly to you blog


(@SenpaiMass) #10

Yeh i changed the permalinks, which has broken the links. The latest ones do link, others i have to manually edit i suppose.


(James Cook) #11

@Alankrit_Choudh What was the issue in the end? I’m having the same problem.

I have installed the plugin, the api connection has been successful and I have comments on the published posts. Not seeing the comments back over on the blog though. I do see the number of replies for each post but when I click into the post the comments aren’t being displayed.


(James Cook) #12

Ignore me. I still had Min number of replies needed set to 5.

I initially skim read this as Min number of replies to show