Do not see comments not link to discourse from wordpress

I have installed WP discourse, after initially having issues related to a curl error when trying to fetch data I have disabled sll verification with the plan to deal with that mess later. I now shows that it successfully connected however i see no comments nor a link to go make comment “join the discussion” etc. I have come through the setting to ensure the default comments are turned off (and not set to show below discourse comments).

The only part of the tutorial i did not do was the composer script add, this may be my issue ? I was not sure where this settings file exists for me to add the dependence manually but as i saw the wp discourse plugin in the admin console i omitted this.

The plugin uses the WordPress comments template. Comments need to be enabled for a post before anything will show up. Are comments enabled for the post?

No, you can ignore that section. It’s an alternate way of installing the plugin.

If you continue to have trouble with this, can you let me know what version of WordPress you are using? Are you publishing posts with the new Block Editor? Are your posts regular posts, or are they a custom post type?

Update: I am able to publish word press post’s to discourse, however still not getting comments to show nor a link showing “Start the discussion”. (post’s that contain videos, show text only on discourse even with the plugin for media, would be awesome to integrate this together.

what version of WordPress you are using
WordPress 5.0.3

re you publishing posts with the new Block Editor
No

Are your posts regular posts, or are they a custom post type?
Video type?
image

It may also be worth mentioning i do not see an API call happen in the query monitor at any point.

1 Like

Are comments enabled for the posts? You can check this by enabling the Discussion checkbox on the editor’s screen options tab, and then scrolling to the bottom of the editor to the Discussion section. The Allow Comments checkbox in that section needs to be checked.

&

Yet still no discourse here :frowning:

I forgot to ask the most obvious question. Have you enabled Discourse comments?

If that’s not the problem, it may be related to the Video format. Does your theme load the comments template for that format?

Yes I have them enabled:

Here is a new development however; there is text saying there are no comments…

So it is showing this text indicating there is a configuration error

So … I never see a call to pull comments coming in when i load the post page on WP - I have NOT configured a webhook, perhaps i misread the documentation. Is a webhook required(as it was when i setup the sister plugin for ghost)?

If you haven’t configured a webhook, make sure that the Sync Comment Data webhook is not enabled. If you’d like to see the results faster, you could try configuring the webhook. All the details for that can be found on the plugin’s Webhooks Settings tab.

This WAS the issue. :slight_smile: Another developer working on this last night had create a web hook and set it to sync; as soon as my train of thought lead toward there i saw that, turned it off and it worked.

Now the only thing left on my plate for this is styling, and while i think i can handle it without help i wanted to draw your attention to it in case others see this as well. The comments on the word press page are behaving weird when nested/not nested. A reply to the main post/topic will appear nested under any prior comments however a reply to a persons comment which should be nested is showing up as without a indentation! backwards! :smiley:

1 Like

Great! I think the plugin needs to run a test to see if the webhook is working. If it isn’t, the regular API call should be made to fetch comments from Discourse.

1 Like