"Comments on this entry are closed"


(Mark Ridsdill Smith) #1

Thanks for all the detailed and step by step instructions for installing the Wordpress plugin.

I’ve successfully linked up my blog, I can publish posts onto my discourse forum, and comments on the forum are now (after a bit of fiddling) showing up on the blog.

But on the blog I now also have a piece of text next to the comment box that reads “Comments on this entry are now closed” - which is obviously misleading and incorrect. I think this is coming from Wordpress but I can’t find where and how to turn it off. Can anyone help? Thanks in advance.


(Simon Cossar) #2

Yes, that is coming from WordPress. Opening the comments for the post should solve the problem: Enable and Disable Comments for Published Posts and Pages — Support — WordPress.com.


(Mark Ridsdill Smith) #3

Thanks Simon. I found the place to Enable and Disable comments - this gets rid of the “comments on this entry are closed”, but instead opens up Wordpress comments. I thought the plugin showed old Wordpress comments but that new Wordpress comments were disabled. I’ve played around with the plugin settings but can’t find a way to get rid of the Wordpress comments. Am I missing something?

I’ve also discovered that the Discourse comments are unexpectedly showing at the top of the page. How do I get rid of this? I can’t find a setting anywhere to turn it off.


(Simon Cossar) #4

If you have enabled the ‘Show Existing WP Comments’ setting (found on the Commenting Settings tab), the WordPress comments template will be displayed. To show old WordPress comments without displaying the form for adding new WordPress comments will require a customization to your theme - it’s not something the WP Discourse plugin can control.

Can you share a link to a page where this is happening?


(Mark Ridsdill Smith) #5

Thanks. Strangely, even when I do not have the “Show Existing WP Comments” enabled, the Wordpress comments box still seems to show. Perhaps that is something do do with my theme and I’ll need to get someone to customise it to get rid of it.

Yes, I think you should be able to see it on this page:


(Simon Cossar) #6

Thanks for the link. There seems to be an error in your theme. When I open the page with my browser’s developer tools I’m seeing tags that should be in the head section (meta, link, and script tags) being displayed in the page’s body. Possibly there is a missing closing tag somewhere in your code.