Composer stalls on "Processing Upload" when using events plugin

We are currently unable to upload files (mainly, we paste images) into a post.

The composer stalls on “Processing Upload” and spins forever…

I have tried rebooting, and rebuilding the app, but it doesn’t fix the problem. I’ve also tried searching here but can’t find a previous question like this?

I’d be grateful for some support on this. Thank you!

1 Like

Is it a standard install? Are you using cloudflare? Are uploads on S3? Behind a load balancer or reverse proxy?


Hi @pfaffman - It’s a standard Digitalocean install. It’s on a Digitalocean Droplet.


Aka. One-click? If so then you will get an answer that is unsupported way and that’s it.

My not-so-helpful 2 cents is you should spin on a new pure droplet, reinstall Discourse offical way and you are good to go ask here (after you have tried if safe-mode helps etc. ordinary ways to be sure there is no conflict between plugins, theme components and so on)-


Nothing much has changed recently, except upgraded recently to v2.9.0.beta9. I’m going to roll back to an earlier version as see if it’ll come back, and yes then try disabling plubins…

1 Like

@pfaffman and @Jagster - it’s diagnosed, by process of elimination, it seems that it was the discourse-events plugin (which I have now disabled).

Thanks for the support :slight_smile:


well that’s not good at all as some of us really need the events plugin :wink: – I have also just confirmed that this is indeed the case. Hopefully someone will fix the issue asap.

My present install is on AWS on an Ubuntu ec2 with the standard install (Docker) … I know this has nothing to do with this issue but thought I would add it for clarification and remove hosting as a suspect.

I am now reverting back to 2.9.0.beta8 vs 2.9.0.beta9, tested on other environments, 2.9.0.beta8 and events plugin together allow image uploads through the Composer WYSIWYG again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.