Image upload stuck with "Processing" message

Hi! I am kicking the tires on Discourse looking at adopting it for a new forum project. I have built a fresh environment using the latest version (2.0.8.beta6). While testing image uploads, I am running into an issue where small image uploads work fine, but larger image uploads show a “Processing” message that never seems to progress and resolve to an actual imbedded image. Instead, the post retains these blue links instead of the image - and clicking the links produces no response.

the screenshot below is of 3 images, 2 largish and one small. In my limited testing, the size threshold between success and failure seems to be about 400 kb.

1 Like

I believe you can disable the image processing feature.

@Joshagos thanks for the heads up. I just tried disabling " composer media optimization image enabled" in settings and uploading larger files now works. Sounds like this is a client-side component. I am not seeing any errors in the browser JS console. I think that I saw this might be a new feature in the release I am running. Is this a know issue? Or should I file a bug?

Well, I’m glad that you have things all sorted out now! :slight_smile:

I’d prefer have image compression enabled. Sounds like a really good idea :slight_smile: .

I just tried enabling “force https” and now it works properly. So possibly this is a prerequisite. @Falco , can you confirm. Odd that no sign of trouble seems to be logged in JS console.

4 Likes

Yes, you must have https enabled for any new browser features.

Since any new Discourse install following our only official install guide gets https by default, it’s assumed to be working nowadays.

Did you deviate from the guide in any way?

3 Likes

New intsalls start with “force https” disabled. The guide does instruct you to enable it once you confirm htttps is actually working. I had not done that yet. All good :+1:

1 Like

But it doesn’t. It’s broken, and I think if you check your text site you’ll see that it’s no longer enabled. Test for valid cert to enable force_https is broken, leaving it off when it should be on.

I just ran into this problem with the Processing step never completing as well, but turning on force_https did not solve it for me (using the current version of Brave in macOS 11.6 Big Sur). I worked around the problem by converting the 3.5 MB PNG image to a 524 KB JPEG.

Interestingly, the dashboard suggestion for the day was to turn on force_https, so I wasn’t perturbed to do that, but I’m guessing it wasn’t in the default instructions when my tech guy installed as well.

1 Like

I managed to fix the problem by disabling the image optimization feature described in the post here, and now it works.

Since it’s a client side feature, make sure you do a hard refresh in the browser before attempting the upload again - that’s important, otherwise it’ll continue to fail :slight_smile:

I think that you just needed to do a hard reload after the force_https.

1 Like