Connection Reset By Peer

Installed a fresh copy in a Digital Ocean droplet, everything goes through fine until creating an admin account which never gets sent. I’ve looked through the troubleshooting topic and tried several option, even the telnet goes through no problem. When performing the doctor checkup I receive the following

Blockquote

==================== MAIL TEST ====================
For a robust test, get an address from http://www.mail-tester.com/
Or just send a test message to yourself.
Email address for mail test? (‘n’ to skip) [office@indiebasement.live]: 2tonwaffle@thecollective.network
Sending mail to 2tonwaffle@thecollective.network. . .
Testing sending to 2tonwaffle@thecollective.network using mail.hover.com:465, username:office@indiebasement.live with plain auth.
======================================== ERROR ========================================
UNEXPECTED ERROR

Connection reset by peer

====================================== SOLUTION =======================================
This is not a common error. No recommended solution exists!

Please report the exact error message above to https://meta.discourse.org/
(And a solution, if you find one!)

Replacing: SMTP_PASSWORD
Replacing: LETSENCRYPT_ACCOUNT_EMAIL
Replacing: DEVELOPER_EMAILS
Replacing: DISCOURSE_DB_PASSWORD
Replacing: Sending mail to

==================== DONE! ====================

I check the email which I have through Hover and I’m able to send and receive email fine when testing to another email address.

Have you tried a different port (e.g. 587)

465 needs additional configuration depending upon how the SMTPS server is set up.

Changing to that port (587) did the trick, thank you.

1 Like